Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-117930

Sticky pistons, slime blocks, and other blocks being moved may disappear when chunks load/unload

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.11.2, Minecraft 1.12
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Vanilla server on mcprohosting
    • Confirmation Status:
      Unconfirmed

      Description

      On a multiplayer server, I have built a sweeping-style mob farm kindof inspired by the one Mumbo built in this video: https://www.youtube.com/watch?v=dMf6JLEJW74

      You can see a screenshot of the main sweeping mechanism of my design in the attachment. The main operation is as follows:

      • Pulse one sticky piston for a single tick to make it push all of the other blocks away one block and leave them there.
      • Pulse the other sticky piston for two ticks so that a slime block grabs onto the first piston and pulls it in.
      • Repeat until you get to the end of the track and then reverse the pattern.

      This is basically a flying machine, except that it's in a track.

      The bug is this:
      I had been working on this machine, and everything was fine. Then I teleported away to help with something (I'm an operator on an open server). When I teleported back, all of the blocks in these flying machines were completely GONE. I had two sweepers, totaling four sticky pistons, eight slime blocks, and twelve granite blocks. Every single one of those blocks was gone.

      So my best guess is that there is a race condition between pistons moving blocks and chunks loading or unloading, which caused them to all just get deleted. What's really odd, though, is that ALL of them are gone. At any one time, the base of one of those pistons is not moving.

      I wouldn't be surprised if this bug report is a dupe of something, but I did try pretty hard to search for related bugs. I looked for things on pistons and slime blocks disappearing, blocks being moved by pistons disappearing, and flying machines disappearing. I did find one or two things for MCPE that seem a bit related, but this bug for PC.

      I've been encountering a lot of redstone related problems due to chunk unloading on this server, far more severe than any other. The machine in question is built in a place that gets a lot of spurious activity, so I'm guessing that the chunks that this machine is in are being constantly loaded and unloaded.

        Attachments

        1. 2017-06-14_20.48.51.png
          2017-06-14_20.48.51.png
          345 kB
        2. 2017-06-14_20.48.27.png
          2017-06-14_20.48.27.png
          273 kB
        3. 2017-05-28_09.51.31.png
          2017-05-28_09.51.31.png
          727 kB
        4. 2017-05-28_09.51.15.png
          2017-05-28_09.51.15.png
          658 kB
        5. 2017-05-28_09.41.22.png
          2017-05-28_09.41.22.png
          676 kB
        6. 2017-05-26_00.05.49.png
          2017-05-26_00.05.49.png
          749 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                theosib2 Timothy Miller
              • Votes:
                12 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: