Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-6151

"id": "1.5.2" altered to "id": "legacy" in versions 1.5.2 and prior [i.e., can't start Minecraft versions older than 1.6]

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 2.0.806 (Windows)
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:
      Windows 7, Java 8.0.1210.13
    • Confirmation Status:
      Plausible

      Description

      I was asked by [Mod] Kumasasa on my previous ticket to create a separate one on this issue, since they are considered separate problems. The previous one can be found here: MCL-5837

      The day the new launcher was released a change took place in the 1.5.2 (and older versions) .json file from "id": "1.5.2" to "id": "legacy", of course that's not the only difference, but it is the first and most notable change, and it must have something to do with the problems people are getting when installing modded versions of the game on those versions.

      Now, of course mods are not officially supported, but the problem here is with the new launcher and the changes it brought (the old launcher did not have these problems).
      When creating a new profile for a modded version, of course, the first step is to create a copy of the version needed to install the mod in the .minecraft/versions file. After that it is required to make the following changes:

      1. The user has to change the version (in my case 1.5.2) name to something else, as well as the .jar and .json
      2. After that, the "id": "(version)" right at the beginning of the .json file needs to match the versions' name as well.

      The problem here lies in the fact that some sort of change was made that screwed up this process, One of the changes being the alteration of the "id": "1.5.2" into "id": "legacy" in the new launchers' version of the .json file.

      This can't be ignored as a non-Launcher issue, because as soon as the update took place, the change I described earlier happened, and no modded versions would show up in the new Launcher's versions list, even though they've worked for years with the previous launcher.
      I'm well aware the problem isn't just (probably) with the .json file, but this change needs to be addressed since things worked perfectly before, and I've seen other people unable to use modded versions of 1.5.2 with the new launcher.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ParagoN Goncalo Virginia
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK: