Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-5857

Minecraft just freezes after a while - began with the new launcher

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Incomplete
    • Affects Version/s: 2.0.806 (Windows)
    • Fix Version/s: None
    • Component/s: None
    • Environment:

      Windows 7 Pro 64bit, Windows 8.1 64bit, attached runtime (jre 1.8.0.25), also custom picked jre 1.8.111

    • Confirmation Status:
      Unconfirmed

      Description

      This started happening after the old launcher self-updated to the new one (which btw. annoyed me - you shall add a setting to ask about the upgrading). I have a rather large minecraft world (about 70 MB). I try to tell everything about it:
      1. It's really large and lot of building has been done to it
      2. The world spawn and the spawn chunks have been moved from the original location to 10000 90 10000
      3. I use a lot of command blocks work (for the terraforming and landscaping, more specified below)
      4. gamerules - tickspeed 3000, daylightcycle false, commandblockoutput false sendfeedback false, keepinventory true.
      5. The world was created on 1.8.9. version of the game

      These days I'm doing terraforming. I use quite a lot of commands, such as:
      /execute @p ~ ~ ~ /fill ~-2 ~-2 ~-2 ~2 ~3 ~2 air 0 replace water
      to drain water around me when changing the river flow direction, and similar. I allways put the command block near me or into the spawn chunks.
      When I do that and I go to the river, it all behaves fine like it used to, with the old launcher. However, after some time, approximately about 30 seconds, the game just freezes, java runtime environment (SE) stops responding and crashes, so you have to restart the game, and the interesting fact is, that the latest progress isn't even saved properly.

      This was tested on two machines, also with backups of the same world. I think that the new launcher must somehow fuck this world when the game loads it, because it doesn't happen on any other world (tested on both computers as well). I also use the JVM Argument -Xmx4G to provide bigger RAM to the game, but with no help. There went a lot of time and effort to ths world, and since it's so big, the recreating and copying is not the way. I can't tell what is wrong, so please help.

      _______
      EDIT:
      I've done further testing, I removed all of the command blocks. I seems to be rendering problem, but I don'thave a clue why, because I'm running same configuration, as with the old launcher, which worked just fine. The freeze also happens when I make a quick move, for example fall down after flying in creative - from about 40 block height. It stopped just above the ground.

      _______
      EDIT:
      So I tested another large world, the Terra swoop force map (v 1.5.2. for MC 1.11.2.) which worked fine with the old launcher, now it stops almost instantly after moving (it is a very large world), so it must be a rendering issue and it must be something to do with the old launcher, beacause I have the same config, play on the same world, but it does this.

      Also, i forgot to mention - I do all the tests in 1.11.1 version as well, with the same result unfortunatelly.
      ________
      EDIT:
      So I must confirm, it is the new launcher. When i logged in using the technic plaform launcher, it behaves just like it used to, the normal was. I think I'm gonna stick with the technic launcher, at least temporarily

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              KMBros KMBros
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: