Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-18836

Launcher Fails to load after new update (linux)


    • Icon: Bug Bug
    • Resolution: Fixed
    • 2.2.8540 (Linux)
    • 2.2.3554 (Linux)
    • Minecraft Launcher
    • None
    • Unconfirmed

      My launcher recently automatically updated upon start. After this update happened, I haven't been able to get the launcher to load. So I went into my files and got out the launcher_log.txt file and examined it a bit.

      I found an error message in the txt file, being:

      [Error: 2021-07-16 00:19:44.308064404: LauncherPluginLinux.cpp(20)] Failed to load /home/bstrazishar/.minecraft/launcher/liblauncher.so: libsecret-1.so.0: cannot open shared object file: No such file or directory

      Reading some other bug reports from earlier this June, I saw other users were experiencing similar issues when the launcher was updated back in June. It's basically the same issue but a little bit different. 

      So, I have tried uninstalling the launcher and reinstalling multiple times, I have tried updating my linux environment, upgrading all packages, the whole deal. But nothing seems to work. 

      Is there anything I can do to fix this? If so please help!

      I have read all the old bug reports as well, so please submit new information for me. Thank you all and have a wonderful day.

      Below I have attached both launcher log files.

            Unassigned Unassigned
            benjamin204 Ben Strazsiahr
            0 Vote for this issue
            3 Start watching this issue