Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-16044

versions not compatible with Java 11 crashing on Linux

    XMLWordPrintable

Details

    • Unconfirmed

    Description

      Versions of Minecraft: Java Edition that are incompatible with Java 11 are crashing on Linux when installing via the .deb file, such as 1.8.9.  This is due to the fact that one of the dependencies of the Minecraft launcher that is installed when running the .deb file is the "default-jre" package, which has recently moved over to Java 11 after using Java 8 for quite some time.  As such, anyone who uses the .deb file to install the Minecraft launcher cannot use older versions of Minecraft that rely on Java 8 to work.  I was only able to fix the issue after manually installing Java 8 as well as the Minecraft launcher.  I suggest that the launcher download Java 8 into the .minecraft folder and use that when launching versions of the game that require Java 8 to work properly, such as 1.8.9.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              OldWorldOrder Joey Reinhart
              Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: