Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-15444

Old versions of Minecraft do not launch on Linux

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 2.1.17785 (Linux)
    • Fix Version/s: None
    • Component/s: Minecraft Launcher
    • Labels:
    • Environment:
      Ubuntu 20.04 LTS Focal Fossa
    • Confirmation Status:
      Unconfirmed

      Description

      On attempting to launch version 1.0, Minecraft Launcher throws an exit code 0 and says it couldn't launch, while the terminal shows this error. I am using the default apt package and I have Java 8 (non headed) installed.

       

      [1019/220003.727047:WARNING:x11_util.cc(1349)] X error received: serial 1135, error_code 3 (BadWindo
      w (invalid Window parameter)), request_code 4, minor_code 0 (X_DestroyWindow)

       

      EDIT: This works if you set the Java runtime to something else, but the error code should likely be more descriptive

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sirsnowy7 Christian J Phillips
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: