[MC-68642] Certain characters cannot be typed on certain keyboard layouts ("AltGr" behaving like "Ctrl") Created: 21/Aug/14  Updated: 23/Jun/16  Resolved: 03/Apr/15

Status: Resolved
Project: Minecraft: Java Edition
Component/s: None
Affects Version/s: Minecraft 14w34d, Minecraft 1.8-pre1, Minecraft 1.8-pre2, Minecraft 1.8-pre3, Minecraft 1.8, Minecraft 1.8.1-pre1, Minecraft 1.8.1, Minecraft 1.8.2-pre1, Minecraft 1.8.2-pre4, Minecraft 1.8.2-pre5, Minecraft 1.8.2-pre6, Minecraft 1.8.3
Fix Version/s: Minecraft 1.8.4

Type: Bug
Reporter: DBZ Assignee: [Mojang] Grum (Erik Broes)
Resolution: Fixed Votes: 42
Labels: None
Environment:

Windows 7, Croatian keyboard(HR)


Issue Links:
Duplicate
is duplicated by MC-68759 Cannot make @ ingame Resolved
is duplicated by MC-69208 Slovakia cant write @ Resolved
is duplicated by MC-69516 Unable to write @ on SLK Keyboard lan... Resolved
is duplicated by MC-69564 Can't use alt+gr on Slovenian keyboard Resolved
is duplicated by MC-69570 Can not type the @ symbol Resolved
is duplicated by MC-69805 Alt gr in MC acts like ctrl , so we c... Resolved
is duplicated by MC-70240 Sign 'at sign' does not working prope... Resolved
is duplicated by MC-70433 Can't type {,@,&,# in command or chat Resolved
is duplicated by MC-71122 It's duplicate, but for reason, can't... Resolved
is duplicated by MC-72988 Can't write @ symol. Resolved
is duplicated by MC-74684 @ doesn't work Resolved
is duplicated by MC-77050 Typing polish letters in game chat is... Resolved
is duplicated by MC-79362 Special characters don't work on chat... Resolved
is duplicated by MC-79450 Alt+V equals Ctrl+v Resolved
Relates
relates to MC-6436 Incomplete support of dead keys on no... Resolved
relates to MC-42171 "~" and "^" not Working on Mac with c... Resolved
relates to MC-68399 Pressing the '<' key takes screenshot... Resolved
relates to MC-68674 Cannot use relative coordinates with ... Resolved
relates to MC-100556 "Alt Gr" on keyboard becomes "LCONTRO... Resolved
CHK:
Confirmation Status: Community Consensus

 Description   

Key "Alt" or "AltGr" acts like "Ctrl" ("Alt" + "V" pastes copied text...). This means you are NOT able to create many characters like "@" or "&".
Thank you Ferenc Nagy for an awesome demonstration video. https://www.youtube.com/watch?v=60_FJPSkUaQ&feature=youtu.be If you don't know what this bug is, check it out! Especially Mojang, please fix this, we can't do commands!



 Comments   
Comment by Sonic [ 21/Aug/14 ]

Incorrect Alt shortcut. Its Alt+86.

Comment by DBZ [ 22/Aug/14 ]

Is 86 v? I've been tying do click Alt and V but i couldn't make @.

Comment by [Mod] Odysseius [ 22/Aug/14 ]

Yes.

Comment by Dobypeti [ 22/Aug/14 ]

alt + v does worked, but in 1.8-pre1 it doesn't

Comment by tera [ 24/Aug/14 ]

It's Alt Gr + V to be exact, on this type of keyboards http://en.wikipedia.org/wiki/AltGr_key#South_Slavic_Latin

Also pressing < will act as F2 and take a screenshot, probably related to this issue.

Comment by DBZ [ 24/Aug/14 ]

On my home keyboard i am also using shortcut Alt Gr + V ,but it also isn't working but most pepole are using Alt + V which isn't working too.

Comment by Dobypeti [ 25/Aug/14 ]

Oh, this happens with # &, too

(& - alt + c | # alt + x )

Comment by Marino [ 28/Aug/14 ]

For me Alt gr + v should create @ but it doesnt

Comment by DBZ [ 28/Aug/14 ]

Me too! I am using Croatian keyboard on which AltGr+V creates @ but now it doesn't.

Comment by Marino [ 28/Aug/14 ]

LOL I use Croatian keyboard too cause i am croatian

Comment by Mateusz Wojtoń [ 29/Aug/14 ]

It also doesn't work for polish letters. Alt key acts like ctrl, so some people cannot create special chars ingame.

Comment by Marino [ 29/Aug/14 ]

Yes thats true like when i try to make @ with alt v it pastes the copyied text cause alt = ctrl , ctrl v

Comment by tera [ 02/Sep/14 ]

Confirmed for 1.8

Comment by Ferenc Nagy [ 03/Sep/14 ]

What's about this? I'm starving for making commands
Hungarian keyboard here :S

Comment by DBZ [ 03/Sep/14 ]

The more votes this issue gets, bigger are chances of Mojang fixing it. So...please vote.

Comment by Ferenc Nagy [ 06/Sep/14 ]

Hi guys at mojang.
I made a video about it, so you can at least confirm it
I hope this will be fixed soon
https://www.youtube.com/watch?v=60_FJPSkUaQ&feature=youtu.be

Comment by Norbert Toth [ 06/Sep/14 ]

This bug exists also in 1.8. I can't write @, & and #...
I'm using hungarian keyboard, and Alt Gr + Í combination takes a screenshot, so every time I type < character, I get a small lag, because of screenshot...

Comment by Ferenc Nagy [ 06/Sep/14 ]

A magyarok szívnak :/ és nem is fogadják el

Comment by [Helper] Marcono1234 [ 10/Oct/14 ]

Norbert Toth, the second part you are describing is probably caused by MC-68399

Comment by Dobypeti [ 28/Oct/14 ]

Helló, ha már magyarokról is szó van
________________________

Not fixed in 1.8 release.

("HU-EN" keyboard)

Comment by qeterme [ 04/Jan/15 ]

Valami fejlemény van már róla? Picikét idegesítő, hogy lassan átállunk 1.8-ra és se színkód, se semmi :S

Comment by tera [ 04/Jan/15 ]

Still not fixed in 1.8.2-pre1.
What does it take for this to get noticed ffs this issue is annoying af and a lot of people are affected by it.

Comment by WojtekPod [ 30/Jan/15 ]

The bug is present in 1.8.2-pre6.

Edited to add: The problem exists in Windows 7 and Windows 8.1, and Polish (programmer keyboard) and US English (American-international keyboard) as well. (In American-international you don't get special characters like "©").
The problem is for both latest Java 7 and Java 8 versions.

Comment by Michael Brabec [ 06/Feb/15 ]

Weird is, that it happens on my computer, but not on my grandfather's...
Both have Windows. I also dualboot with Linux (Ubuntu) and there it works correctly.

Comment by tera [ 14/Feb/15 ]

Is there any point of bumping reports like this and is it allowed?

Comment by Sonic [ 14/Feb/15 ]

I don't think there is, and no, bumping is not allowed.

Comment by Tomáš Misař [ 15/Feb/15 ]

I have the same problem

Comment by Tomáš Misař [ 15/Feb/15 ]

I have the czech keyboard

Comment by Dobypeti [ 02/Mar/15 ]

I have this problem in 1.8.3. Keyboard: HU / Hungarian keyboard

Comment by Jadran Kotnik [ 10/Mar/15 ]

Can confirm on a Slovenian keyboard. And I may have tracked it down. Minecraft checks inside GuiTextField.onKeyDown for CTRL+A/X/C/V explicitly.

public static boolean isKeyComboCtrlV(int key)

{ return key == 47 /* V */ && isCtrlKeyDown(); }

A possible fix would be to check for !isAltKeyDown() as well.

Comment by tera [ 11/Mar/15 ]

The bug is still present in 1.8.3, please update.

Comment by DBZ [ 04/Apr/15 ]

Thank you Mojang for fixing this! It makes our gameplay much easier.

Comment by Michał Respondek [ 05/Apr/15 ]

I'm from Poland and I can't type Polish "ą" and "ć". The former highlights the whole text and the latter copies the highlighted text. Please fix! I'm using Minecraft 1.8.3.

Comment by [Mod] Kumasasa [ 05/Apr/15 ]

@Michał Respondek: This is fixed for next version.

Comment by tera [ 17/Apr/15 ]

Pressing "<" on South Slavic Latin keyboard layout will still act as F2 and take a screenshot in 1.8.4, I believe it is caused by this issue also.

Comment by [Mod] Kumasasa [ 17/Apr/15 ]

@tera: This is MC-68399

Comment by Michał Respondek [ 19/Apr/15 ]

@Kumasasa Thank you alot. I can now write proper Polish!

Comment by [Helper] Fabian Röling [ 30/May/16 ]

I never had the problem mentioned in this report, but since my bug report was marked as duplicate of this, I say it here:
When I try to set a key to Alt Gr (controls menu), it says "LCONTROL" and interferes with left control actions.
Because of that: Confirmed for 1.9.4 and 16w21b.

Generated at Thu Nov 23 05:26:53 CST 2017 using JIRA 7.2.8#72010-sha1:dc33de34ffa065bef267bff4768b99ca94e2c00c.