[MC-129281] Player's position, gamemode, inventory, effects gets reset to an older point upon re-entering a worldsave Created: 08/May/18  Updated: 05/Jun/18  Resolved: 15/May/18

Status: Resolved
Project: Minecraft: Java Edition
Component/s: None
Affects Version/s: Minecraft 18w19a, Minecraft 18w19b
Fix Version/s: Minecraft 18w20a

Type: Bug
Reporter: Meri Diana Assignee: Unassigned
Resolution: Fixed Votes: 9
Labels: gamemode, inventory, player, player-inventory, player-reset, position, reset, resetting

Attachments: File MC129281.mp4    
Issue Links:
Duplicate
is duplicated by MC-129278 Player always appears at initial spaw... Resolved
is duplicated by MC-129437 position and inventory(maybe all the ... Resolved
is duplicated by MC-129454 save issues Resolved
is duplicated by MC-129523 Most recent world won't be saved afte... Resolved
is duplicated by MC-129595 Inventory roll back Resolved
is duplicated by MC-129606 World not working even in B snapshot Resolved
Relates
relates to MC-124901 World spawn is located elsewhere than... Resolved
CHK:
Confirmation Status: Community Consensus

 Description   

Upon entering a world in 18w19a I entered the last time in 18w16a, my player inventory (incl. worn armour or a block on my head like e.g. a carved pumpkin), gamemode, effects as well as my character's position and full rotation in the worldsave gets always reset to one specific point. This solely applies to the player, blocks which were already changed in that world, or e.g. dropped items (which are below the despawn time) persist if you re-enter that world.

If the player had effects applied (in my case it is nightvision) this effect is also persistent, even if you removed it before you logout and reenter the world.

It only seems to happen in:

  • worldsaves which I entered the last time in 1.12.2.
  • worldsaves which I entered the last time in 18w16a, but it does, for example, not happen in a world I entered the last time in 18w05 as well as not in another world of 18w01.

(haven't checked 1.11 and 1.10 yet)

Video showing the issue:

Also, I'd like to add that any builds you've made in a world which you entered the last time in 18w16a vanish upon entering that world in 18w19a (as well as 19b, but this is known to Mojang [ProfMobius tweets, just mentioning it for those reading this bugpost and not knowing]); but if you enter in worlds you entered last time in an older 1.13 snapshot version, e.g. 18w01, the builds will still be in there.



 Comments   
Comment by qmagnet [ 08/May/18 ]

Confirmed for 18w19a

This also happens from a world created in the latest stable release - 1.12.2 when updating to 18w19a
Inventory and player position are always reset to state during previous loaded version

Steps to reproduce:

  • Create a world in 1.12.2
  • Put random blocks in your inventory
  • Update to 18w19a
  • Change items in your inventory
  • Save and quit
  • Reopen world in 18w19a
  • Inventory will be reset to the first update
Comment by Meri Diana [ 08/May/18 ]

qmagnet Hello Mr. Q, I'm very happy to see you around

Thank you very much for the help, I didn't get to test 1.12 worlds (or prior to those) yet, there's just too many bugs in this snapshot version. The setback also happens for me with 1.12.2 worlds, but, oddly, not in worlds I've been last time in 18w05 or 18w01.

Thank you again, have a wonderful week.

Comment by Aaron Rhodes [ 09/May/18 ]

This happened to me, except upon switching to 18w19b, my position and inventory remained the same, but world generation was reset, so any changes I made to the world in the older snapshot were basically undone.

Comment by Meri Diana [ 09/May/18 ]

Aaron Rhodes In which MC version did you enter said resetting world for the last time? 18w16a?
If so, Professor Mobius tweetet that the issue of a "wiped" world, if it was entered last time in 16a, is still not fixed! It is solely fixed for worlds prior to 16a.

Comment by iTechieGamer [ 09/May/18 ]

Looks like the level.dat file doesn't get saved/loaded.

Comment by iTechieGamer [ 09/May/18 ]

Aaron Rhodes See MC-129383

Comment by [Helper] Lord_Quadrato [ 10/May/18 ]

Happens to me too in 18w19b -> Confirmed

Comment by Brock Lievsay [ 13/May/18 ]

Hey Everyone, I know how to fix the resetting inventory/position issue!

 

First, back up your world, (obviously)

Open your world in NBT Explorer

Go to the level.dat -> Data -> 

And delete the entire "Player" Compound tag that you will see.

Your inventory and position will now stay changed the next time you log in!

 

It looks like the new format that 18w19 is using solely the external playerdata folder in the saves now, and having the outdated Player compound tag in the level.dat causes the playerdata data to be overwritten with the outdated data that is in the level.dat

 

You may wish to make a backup of the level.dat just in case they decide to use it again.

Comment by LuxiKeks [ 15/May/18 ]

This looks like it's not an issue anymore in 18w20a. Can somebody confirm?

Comment by qmagnet [ 15/May/18 ]

I confirm it is fixed from loading 1.12 world into new snapshots for game mode and inventory

Comment by Meri Diana [ 15/May/18 ]

My 18w16a worlds (last opened in that snapshot) load including all their content, builds as well as entities, in 18w20a for me as well, seems to be fixed. Didn't check 1.12 worlds, but if Mr. Q says so, then it should be fixed for them as well and this bugpost can be resolved.

Comment by Meri Diana [ 15/May/18 ]

Oh, I just saw, the content/commands inside my commandblocks are wiped though.

New bugpost, or is there no chance one can get those transferred over as well?

I'll check a few other worlds that had CBs inside including 1.12.x worlds, and if their CBs are all wiped, I'd have to tweet that so those who still use CBs know.

Comment by qmagnet [ 15/May/18 ]

Command Blocks only become wiped if they are powered when loading the chunk during a 1.13 conversion, as far as I've tested. My command blocks remain intact, as long as they are not powered.

Comment by Meri Diana [ 15/May/18 ]

My command blocks were not powered, I usually trigger them with a redstone block that I always have ready in my hotbar, or with a button that's attached to them or a block in their vicinity.

I just asked on Twitter, maybe someone can give feedback.

I just conducted a test, created a new world in 1.12.2, added 2 CBs, an unpowered ICB and a powered/always active RCB with "say test". Upon loading that 1.12.2 world in 18w20a, both CBs still had their commands, so for whatever reason, only the worlds I loaded in 18w16a seem to have that issue.

I'll test a bit more.

Comment by qmagnet [ 15/May/18 ]

May be chunk related to areas away from spawn?

Comment by FVbico [ 15/May/18 ]

I already reported it, and it’s all command blocks for me, powered, unpowered, impulse, chain, repeating, every single one of them. (MC-129615)

Comment by qmagnet [ 15/May/18 ]

I'd say this specific bug is fixed though

Comment by FVbico [ 15/May/18 ]

Yup, seems fixed.

Comment by Meri Diana [ 15/May/18 ]

Just quickly @ Mr Q: No, they are nearly all at spawn, I just conducted a test with a 18w16a loaded world and could reproduce it (I proof-recorded it); interestingly, an ICB that I had saved pickblocked in my hotbar still got his command, whereas allothers (ICB + CCB + RCB, one powered, one not) with the command "say test" were wiped upon loading them in 18w20a.

  • But this one here seems to be solved.
Generated at Mon Nov 12 22:32:45 CST 2018 using Jira 7.11.2#711002-sha1:fdc329dee91471a641faabfe39b5ff8c0a5b3f66.