[MC-129233] Items with additional NBT you hold don't show up or "wiggle" up and down; damaged tools partially don't work anymore Created: 08/May/18  Updated: 11/May/18  Resolved: 09/May/18

Status: Resolved
Project: Minecraft: Java Edition
Component/s: None
Affects Version/s: Minecraft 18w19a
Fix Version/s: Minecraft 18w19b

Type: Bug
Reporter: Meri Diana Assignee: [Mojang] Grum (Erik Broes)
Resolution: Fixed Votes: 52
Labels: display, enchant, enchanted, enchanted-book, enchanted-items, nbt, tools

Attachments: PNG File 2018-05-08_16.09.07.png     PNG File 2018-05-08_16.09.14.png     File crazy sword.mp4     File MC129233II.mp4     File MC129233.mp4     GIF File minecraft.gif    
Issue Links:
Duplicate
is duplicated by MC-129224 broken trident Resolved
is duplicated by MC-129227 Tools only work once. Resolved
is duplicated by MC-129228 Tools stop working after first use Resolved
is duplicated by MC-129229 Tools only work for destroying one bl... Resolved
is duplicated by MC-129234 Maps glitch out/ become invisible whe... Resolved
is duplicated by MC-129239 Items bob up and down when walking on... Resolved
is duplicated by MC-129243 Bug with commands!!!!! Resolved
is duplicated by MC-129248 Trident Graphical Glitch Resolved
is duplicated by MC-129250 Tools don't work properly Resolved
is duplicated by MC-129255 Tools can only break one block Resolved
is duplicated by MC-129260 Tools don't work in snapshot 18w19a Resolved
is duplicated by MC-129264 All Tools Are Broken. Resolved
is duplicated by MC-129267 Tools acting odd after they are used Resolved
is duplicated by MC-129268 Cannot cut wood with wooden axe Resolved
is duplicated by MC-129269 Tools shiver like mad and are mostly ... Resolved
is duplicated by MC-129272 need tools fixed Resolved
is duplicated by MC-129279 Some items click infinitely with the ... Resolved
is duplicated by MC-129283 tools (wood or stone) are broken Resolved
is duplicated by MC-129289 Potion animation bug Resolved
is duplicated by MC-129290 NBT items dissapear in hand Resolved
is duplicated by MC-129291 Can only break ONE block then tool gl... Resolved
is duplicated by MC-129295 Cannot break more than ONE block per ... Resolved
is duplicated by MC-129297 Tridents are broken! Resolved
is duplicated by MC-129301 Item Bobbing! Resolved
is duplicated by MC-129307 Error with the map textures Resolved
is duplicated by MC-129308 Can't Mine with Tools Resolved
is duplicated by MC-129310 Unable to harvest past the first block Resolved
is duplicated by MC-129314 Tools not working Resolved
is duplicated by MC-129316 Tools not working Resolved
is duplicated by MC-129319 Can't Look down at maps Resolved
is duplicated by MC-129321 Multiplayer- tools can only break one... Resolved
is duplicated by MC-129326 Maps glitch up and down Resolved
is duplicated by MC-129329 Tools Not Working After Getting Used ... Resolved
is duplicated by MC-129330 Critical bug in Snapshot 18w19a cause... Resolved
is duplicated by MC-129332 Pickaxes only usable once Resolved
is duplicated by MC-129333 All pickaxes break blocks, then after... Resolved
is duplicated by MC-129340 Tools can not be used properly all th... Resolved
is duplicated by MC-129341 Snapshot 18w19a: axe or pickaxe can b... Resolved
is duplicated by MC-129342 Enchanted weapons and tools Resolved
is duplicated by MC-129343 Tools not working in Snapshot 18w19a Resolved
is duplicated by MC-129350 left click issue only with tool iin hand Resolved
is duplicated by MC-129351 Glitching enchanted items while holding Resolved
is duplicated by MC-129352 Cannot mine blocks or cut down trees ... Resolved
is duplicated by MC-129353 Map and items held in hand glitch out Resolved
is duplicated by MC-129362 Potion items are bugging while holdin... Resolved
Relates
relates to MC-129221 Putting item with NBT in anvil interf... Resolved
relates to MC-129282 Items with NBT cannot stack Resolved
relates to MC-129232 Command NBT comparisons that include ... Resolved
CHK:
Confirmation Status: Confirmed

 Description   

Issue 1:
Holding certain items doesn't display them when you hold them, see screenshots.

This occurs e.g. with enchanted swords, potions, books, possibly with anything with additional NBT?

Issue 2:
Some items "wiggle" up and down in the player main- as well as offhand, e.g. elytra (both enchanted as well as unenchanted, both undamaged as well as damaged), or dyed leather armour (but apparently not regular undyed leather armour), see video:

Issue 3:
Undamaged unenchanted tools work (leftclick), e.g. you can mine blocks with a pickaxe, you can shovel dirt; but as soon as the tool is damaged, it ceases to work, neither pickaxe nor shovel can mine any further block.

Enchanted tools, also undamaged ones, don't work at all (leftclick), see:

Rightclicking though, e.g. hoeing dirt into farmland or creating a pathblock with the shovel still works, with damaged as well as undamaged, enchanted as well as unenchanted tools, see video:



 Comments   
Comment by Lord_Quadrato [ 08/May/18 ]

Confirmed (18w19a)

Comment by Jakob Knigga [ 08/May/18 ]

So, it appears that it's not a visual glitch. Occasionally you can see the item flash quickly in the bottom right (right handed) as if it's just being switched back and forth quickly. Also if it's a tool, it no longer functions.

Comment by Meri Diana [ 08/May/18 ]

Exactly, that's why I chose in the title "too far to the right", as they are flashing into the viewpoint if you move your player. - Interesting regarding the tool not working though, haven't tested that, thanks a lot for the info Jakob Knigga!

Comment by Play Dash Number f800f8 000000 [ 08/May/18 ]

Likely relates to MC-129239.

Comment by Nigel Todman [ 08/May/18 ]

Yup. My tools also don't work.

I deleted my DIMM and region folders and regenerated my world keeping playerdata/stats

I have my old inventory. But the world is new. Tools don't work.

Server: 18w19a OS: Win7 x64 Java: 1.8.0 Build 171

Update: Crafting a new Wooden Axe. Worked...Once. Then it broke too.

Update 2: Confirmed for Single Player

Steps to reproduce:

1) Start a new world. Any seed.

2) Break 2 wood.

3) Craft Planks.

4) Craft a Crafting Table.

5) Craft Sticks

6) Craft a Wooden Shovel.

7) Observe bug.

Comment by neron [ 08/May/18 ]

I'd like to add that when I tested this bug myself, when allocated 1 gb of ram the item would bob in and out of view , kinda liked switching between two items real fast. When I checked with more ram allocated , It would behave the same as the report above shows.

Comment by Meri Diana [ 08/May/18 ]

Thank you all very much for the additional info, will update it accordingly in a bit!
Unless the mods decide that them tools not working should be rather in a new bugpost?

Just asked, I shall add it to the description, there's a bit of inconsistency with the tools by the way, e.g. shovels and hoes which were used still work on dirt/grass (rightclicking), just not mining the block in the case of the shovel.

Will add an additional video in a bit, thank you all again!

Comment by Meri Diana [ 08/May/18 ]

neron I always dedicate 3GB RAM to MC, but still, some items wiggle up and down.
It seems to be sometimes a bit random though, e.g. in one world dyed leather armour didn't "wiggle" at all, whereas in another worldsave it did. No idea currently, why.

Comment by Xavom [ 08/May/18 ]

Same is happening with potions. Out of view and no sound during drinking, sometimes cannot drink.

Comment by Robin Gravel [ 08/May/18 ]

it happens when holding a map and a shield with two hands.

Comment by Jen Ivins [ 08/May/18 ]

After one use all tools and weapons jump while you are holding them and no longer work after they have taken any amount of damage. My computer was being a butt and wouldn't let me take a video, so I took a video with my phone.

crazy sword.mp4

This applies to all un-enchanted shovels, pickaxes, axes, hoes, and swords, as well as the flint and steel, fishing pole, sheers, bow, and trident.

Once you have a bow that starts jumping, switching it out to a new bow doesn't fix the problem. Same with the trident, but you can still throw the trident, while the bow in unusable.

In creative, you can use undamaged tools and there is no issue. But weapons start jumping like they do in survival as soon as you hit an enemy. (The second time I tried to get swords jump in creative it didn't work. So not sure about them.)

seed: -8300275442758179407

Comment by Meri Diana [ 08/May/18 ]

James Rood you're not supposed to really play a snapshot version as if it were a release version
They can corrupt worlds (happened to many people incl. myself), they can break stuff, and, worst case, it may be that you can't play the world you entered in a snapshot version at all anymore in a release version. E.g. in this case, if I entered a world last time in 16a, all builds in there got erased upon entering the worldsave in 19a (should be fixed in the upcoming b-snapshot).

Hence they say to always backup the worlds, even more so if it's a Survival world you play in legit.

But I agree that it's not easy to pinpoint maybe other bugs if you cannot play the game also in Survival, but all we can do is to wait it being fixed, so thank you for any help/additional info

Comment by Shade Heppner [ 08/May/18 ]

Still happens when you repair the tool to full durability with another tool

Comment by Robin Johnson-Wilson [ 08/May/18 ]

Oddly, the axe continues to kill sheep and cows, even though it will not cut down trees. So it's "break" that is broken, while "kill" works fine.

Comment by Paris Crenshaw [ 08/May/18 ]

This also affects items like buried treasure maps.

Comment by luke noddle [ 09/May/18 ]

having same issues myself when is this expected anytime soon ?

Comment by Meri Diana [ 09/May/18 ]

luke noddle Look at the top middle, at "Resolution", it is resolved to "Fixed" now
So maybe it'll be in today's b-snapshot

Comment by luke noddle [ 09/May/18 ]

was gonna say i seen it fixed neverrealized there was the b snap today lol
thank you

Comment by Renate Koelman [ 09/May/18 ]

I was going to ask why all the bugs like this one say "resolved" when I still have the issue, but okay there should be 18w19b now. However, in my launcher (opened at 11:01 GMT+2) it still says the latest snapshot is 18w19a which is weird if 19b is out.

Comment by Paul Blay [ 09/May/18 ]

19b isn't out. Also there is no guarantee that 'future version 1.13+' means 19b. It probably will, but it could be next week if we're unlucky.

Comment by [Mod] FVbico (Steven Verberne) [ 09/May/18 ]
  1. [Mojang] ProfMobius (Thomas Guimbretiere) tweeted yesterday that a 18w19b will release today.
  2. It just changed to "Minecraft 18w19b".
Comment by Meri Diana [ 09/May/18 ]

Renate Koelman Just to explain it a little bit: The developers who fix the bugs change the game code, and all those various code changes have to be implemented in the resulting (new) snapshot. That means the snapshot has to be "built" first, containing all those code changes. The developers mark them here on the bugtracker as fixed as it is fixed on their end, but that very (new snapshot) version is not being pushed out to the launcher/to us immediately.

Just keep in mind that there are often many bugfixes, and of various developers, and some other bugs they may consider a "must-fix" for a next snapshot may not have been fixed yet. They cannot push out a new snapshot for each single bugfix

If you got Twitter, follow the MC Java developers on there, at least one of them will tweet out that there's a new snapshot out as soon as it is Or of course on the minecraft.net blog.

Comment by Adam VlĨko [ 09/May/18 ]

My bug report is duplicate too.

MC-129362

Generated at Sun Jun 24 04:03:02 CDT 2018 using JIRA 7.9.2#79002-sha1:3bb15b68ecd99a30eb364c4c1a393359bcad6278.