[MC-103497] End Dragon Does not respawn Created: 11/Jun/16  Updated: 14/May/17  Resolved: 21/Jun/16

Status: Resolved
Project: Minecraft: Java Edition
Component/s: None
Affects Version/s: Minecraft 1.10
Fix Version/s: Minecraft 1.10.1

Type: Bug
Reporter: Justin Crance Assignee: [Mojang] ProfMobius (Thomas Guimbretiere)
Resolution: Fixed Votes: 26
Labels: ender_crystal, ender_dragon
Environment:

Windows 8


Attachments: PNG File 2016-06-11_14.44.50.png     File level.dat     Zip Archive MC-103497.zip    
Issue Links:
Cloners
is cloned by MC-104736 DragonFight data is not completely re... Open
Duplicate
is duplicated by MC-101341 dragon wont respawn on server Resolved
is duplicated by MC-103475 Ender Dragon will not spawn with Ende... Resolved
is duplicated by MC-103628 Respawning Ender Dragon doesn't work ... Resolved
is duplicated by MC-103682 ender dragon respawn issue Resolved
is duplicated by MC-103791 Enderdragon Not Respawning Resolved
is duplicated by MC-103815 Ender Dragon can't respawn in the sin... Resolved
is duplicated by MC-103839 End Dragon won't respawn on single pl... Resolved
is duplicated by MC-104520 respawn ender dragon Resolved
Relates
relates to MC-97587 End reset (delete file DIM1): no drag... Resolved
CHK:
Confirmation Status: Confirmed

 Description   

Prior to 1.10 I was able to respawn the End Dragon. I recently mined one of the obsidian pillars to gain resources naturally thinking this was the cause of not being able to respawn the dragon I replaced the obsidian but to no avail still no dragon. I tested this on a single player world and was able to respawn the dragon no problem. Not sure why but realms world doesn't want to respawn it. I tried restarting the game numerous times and still no use.

More info: https://bugs.mojang.com/browse/MC-103497?focusedCommentId=312883&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-312883



 Comments   
Comment by [Helper] Anomie X [ 11/Jun/16 ]

I noticed in 1.10 I can't respawn the dragon in my world.

Looking into things a bit more, I find that my level.dat on the server has an empty <DragonFight>. If I go to the end and then /save-all, a <DragonFight> gets created. If I leave the end and restart the server, the <DragonFight> is emptied again.

Most critically, when I attempt to respawn the dragon, the <DragonFight> gets an <ExitPortalLocation> created, but the <y> is 1 lower than the <ExitPortalLocation> I see if I re-create the world with the same seed on the client.

I can reproduce the bug in single player as well:

  1. Create a world
  2. Go to the End, /kill the dragon, leave the End
  3. Exit the world.
    • At this point, you might want to check level.dat to see the Y value for <ExitPortalLocation>.
  4. Load the world then exit it again.
    • At this point, if you look in level.dat you'll see <DragonFlight> is empty.
  5. Load the world, go to the End, and see that respawning the dragon fails.
    • If you trigger a save and check level.dat at this point, you can observe the Y value for <ExitPortalLocation> is one lower than what it was in step 3.

So it looks to me like there are two bugs here:

  1. <DragonFight> isn't being saved back to level.dat if no one goes to the End during the session.
  2. When the <ExitPortalLocation> is being re-determined by scanning the world for a portal thanks to #1, there's an off-by-one error.

Bug #2 makes the game think the crystals are not in the correct position for respawning the dragon. If you break the bedrock and place the crystals one block lower, it will respawn the dragon and will also move the whole portal down one block. Presumably someone could repeat the bug to drill the portal down through the island; I don't know what would happen once it gets past the bottom of the world.

Comment by e s [ 11/Jun/16 ]

Can confirm.
My world generated the end in 1.9.4 on realms. Initially killed the dragon in 1.9.4 then went to respawn the dragon in 1.10 and it would not work. downloaded a backup to local and tried and it still would not respawn, after reading this bug went into creative locally and lowered bedrock on the edge of exit portal and tried repawning. This worked but upon killing the dragon a new end city gateway did not appear which was the reason for doing this in the first place as I found 4 end cities all without ships and wanted to try a different area.

Comment by Erik Öhrn [ 12/Jun/16 ]

I have the exact same problem and the workaround Anomie X posted works for me too.

Comment by KM Tu [ 12/Jun/16 ]

I confirm this issue. My world was also generated in 1.9 on Realms. We killed the dragon in 1.9. When we wanted to respawn it for the first time, Realms got updated to 1.10 and we found out that the End refused to spawn the dragon.

Comment by Jerrod Pope [ 12/Jun/16 ]

Confirming, It's not just realms, my server won't spawn it again either

Comment by [Helper] Les3awe [ 18/Jun/16 ]

Can confirm.

Comment by Joel [ 19/Jun/16 ]

Also seeing this bug in my single player world.

Comment by [Mojang] ProfMobius (Thomas Guimbretiere) [ 21/Jun/16 ]

Anyone with the problem, can you post your level.dat or world so I can have a look at it ?
Also, can you post a console log from the server when you try to start the ritual ?
The tag isn't supposed to be empty at any time. Sounds like there is a silent error happening.

Cheers.

Comment by [Helper] Les3awe [ 21/Jun/16 ]

World Download Link:
https://drive.google.com/open?id=0B9_GivXrbwniMDVueGltX0FLNmc

Comment by [Mod] redstonehelper [ 21/Jun/16 ]

From the log, after entering the end in step 5 of the reproduction steps outlined in the first comment on this ticket:

[12:22:02] [Server thread/INFO]: Scanning for legacy world dragon fight...
[12:22:02] [Server thread/INFO]: Found that the dragon has been killed in this world already.

Comment by reinder anne johannes stegen [ 22/Jun/16 ]

here a level.dat
https://drive.google.com/open?id=0B3I6TisdGE-7YnJCMHlXV1ZsU3c

Comment by [Helper] Anomie X [ 22/Jun/16 ]

I note this bug isn't 100% fixed. There are four possible situations:

  1. The world was never affected by this bug. Now fixed, it won't be affected in the future.
  2. The world was affected, and is currently missing <DragonFight>. Now fixed, the legacy scanning will work.
  3. The world was affected, and currently has <DragonFight> but not <ExitPortalLocation>. Now fixed, the legacy scanning will work.
  4. The world was affected, and currently has the incorrect <ExitPortalLocation> due to 1.10's bad scanning. Not fixed, the broken <ExitPortalLocation> will continue to be used, preventing the expected respawning. A world in this situation is attached.

A world in situation #4 can be fixed manually in several ways:

  • Using 1.10, go to the Overworld or Nether then restart the server twice. That triggers the bug and puts the world into situation #2. Then upgrade to 1.10.1.
  • Using an NBT editor, delete the <ExitPortalLocation>. That puts the world into situation #3.
  • Using an NBT editor, add one to the <Y> value inside the <ExitPortalLocation>. That effectively puts the world into situation #1.
  • Break the bedrock rim and place the crystals one block lower, or break the exit portal blocks and place the crystals inside the basin. This will regenerate the exit portal one block lower, making the bugged <ExitPortalLocation> now be correct.
Comment by Stef Heck [ 22/Jun/16 ]

So now, eh... The problem got fixed. I wanna continue on this: I just killed the Ender Dragon for the second time (first one in 1.10 and today in 1.10.1) I only have 1 End Gateway: new ones aren't generating...

Comment by [Helper] Anomie X [ 22/Jun/16 ]

I suspect that the loss of <DragonFight> also reset the list of gateways, so your second gateway generated at exactly the same place as the first. If you kill the dragon a third time, do you get a new gateway?

Comment by Stef Heck [ 22/Jun/16 ]

So that means I will only have 19 End Gateways maximum instead of 20?

Comment by [Helper] Anomie X [ 22/Jun/16 ]

It probably means you'll have to kill the dragon 21 times (including the two you already did, so 19 more) to get all 20 gateways, rather than only 20 times.

Comment by Stef Heck [ 22/Jun/16 ]

That's weird, because I didn't get that much experience orbs as the "First Dragon" should give.

Comment by squeekywheel [ 27/Jun/16 ]

Can confirm that situation 4 as pointed out by Anomie X is definitely still a bug and impacted my survival world. Resolved with some creative mode changes to the end portal as suggested. Would still recommend reopening the bug since this is likely to be fairly common.

Comment by [Mod] redstonehelper [ 27/Jun/16 ]

Someone please create a new ticket for whichever part of this ticket is still happening in 1.10.2 and refer to this ticket in the description.

Comment by [Helper] Anomie X [ 27/Jun/16 ]

Done, MC-104736.

Comment by Dolf Gulicher [ 04/Jan/17 ]

The problem still exists for me. I have the situation 3 as described in Anomie X's comment 22/Jun/16.
My world however was created in a very early version of Minecraft, years ago. It was updated to version 1.8 and stayed there until I found that in my profile it was set to use that version. Now I have updated to 1.11.2 and because the new additions to the End I wanted to go back and can, but alas cannot respawn the Dragon.
Any advice would be appreciated.

Comment by RimaNari [ 06/Jan/17 ]

@Dolf Gulicher: Please refer to MC-104736, as apparently any further discussion of this issue is supposed to happen there. (Although I believe the title of MC-104736 is not correct, as someone updating from 1.8 to e.g. 1.11.2 will experience an issue, but the world never got corrupted by MC-103497...)

You should find a workaround for situation 3 there.

Generated at Thu Jan 18 19:21:40 CST 2018 using JIRA 7.2.8#72010-sha1:dc33de34ffa065bef267bff4768b99ca94e2c00c.