Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-63121

Custom Blocks fail to load if register_to_creative_menu property is set

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Resolution: Unresolved
    • Affects Version/s: 1.16.200.57 Beta, 1.16.200.56 Beta, 1.16.200.55 Beta, 1.16.200.53 Beta, 1.16.200.52 Beta, 1.16.200.51 Beta, 1.16.100.60 Beta, 1.16.30.53 RTX Beta, 1.16.100.58 Beta, 1.16.100.57 Beta, 1.16.100.56 Beta, 1.16.100.54 Beta, 1.16.100.53 Beta, 1.16.100.52 Beta, 1.16.100.50 Beta, 1.16.20.54 Beta, 1.16.20.53 Beta, 1.16.20.52 Beta, 1.16.20.50 Beta, 1.16.0.68 Beta, 1.16.0.67 Beta, 1.16.0.64 Beta, 1.16.0.63 Beta, 1.16.0.61 Beta, 1.16.0.59 Beta, 1.16.0.57 Beta, 1.16.0.58 Beta, 1.16.0.55 Beta, 1.16.0.53 Beta, 1.16.0.51 Beta, 1.15.0.55 Beta, 1.15.0.54 Beta, 1.15.0.53 Beta, 1.15.0.51 Beta, 1.16.0, 1.16.1, 1.16.10, 1.16.21, 1.16.20, 1.16.40 Hotfix, 1.16.100.59 Beta, 1.16.100
    • Fix Version/s: 1.15.0.56 Beta
    • Labels:
      None
    • Confirmation Status:
      Community Consensus
    • Platform:
      Windows 10 Mobile
    • ADO:
      309574

      Description

      All custom blocks that are registered to the creative menu fail to load with following error.

      [Blocks][error]-block_definitions | C:/Users/%USER%/AppData/Local/Packages/Microsoft.MinecraftUWP_8wekyb3d8bbwe/LocalState/games/com.mojang/minecraftWorlds/NM5DXvP4AAA=/behavior_packs/FC_B | blocks/block_acacia.json | description | register_to_creative_menu | child 'register_to_creative_menu' not valid here.

      [Blocks][error]-block_definitions | C:/Users/%USER%/AppData/Local/Packages/Microsoft.MinecraftUWP_8wekyb3d8bbwe/LocalState/games/com.mojang/minecraftWorlds/NM5DXvP4AAA=/behavior_packs/FC_B | blocks/block_acacia.json | Failed to verify block

       

      I have attached the block file from this add-on and i have found some what of a work around to get it to work until it is fixed.

      if you remove the property "register_to_creative_menu" from the description the blocks will load and function properly. (they will not be in the creative menu but they will be available for /give commands and everything else)

      I hope this gets resolved quickly as it does make it much more tedious to test custom blocks.

      Thanks

       

       

        Attachments

          Issue Links

            Activity

              People

              Reporter:
              Zephira Zephira
              Votes:
              51 Vote for this issue
              Watchers:
              31 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: