Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-62697

minecraft:addrider fails to work properly with horses

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Awaiting Response
    • Affects Version/s: 1.14.30.51 Beta, 1.14.25.1 Beta, 1.14.20 Hotfix, 1.14.1 Hotfix
    • Fix Version/s: None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Windows 10 - PC

      Description

      When making an addon, I found an annoying issue relating to mobs. When using minecraft:addrider to add a mob on a horse, certain mobs will not spawn on the horse even when there is nothing stopping them from doing so. This applies to wither skeletons, pigmen, and possibly some other mobs in the game.

      Common mobs such as Skeletons and Zombies work fine for minecraft:addrider

      I used the correct definitions and names to spawn them, yet the only indication they existed was a single sound they play. It seems the game removes them immediately when they spawn, however I am in normal difficulty. This should not happen.

      As seen in this image, I set up Skeleton Horses to have Zombie Pigmen always ride them. Everything is correctly set up, as using zombies works fine.

      (It seems that all equine mobs are affected by this regardless of variation. I have no idea if pigs and other ridable mobs are affected by this too. This needs more testing.)

        Attachments

        1. Untitled.png
          Untitled.png
          1.96 MB
        2. debug.mcpack
          14 kB

          Activity

            People

            Reporter:
            Cipheroid Tstu0001
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: