Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-46271

The Zombie Doctor Achievement doesn’t work!!

    XMLWordPrintable

    Details

    • Confirmation Status:
      Community Consensus
    • Platform:
      Xbox One
    • ADO:
      196775

      Description

      Verification builds:

      1.11.1 Android

      Summary:
      Successfully curing a zombie villager does not grant the zombie doctor achievement

      Steps to Reproduce:

      1. Use a world without cheats enabled
      1. cure a zombie villager with the provided golden apple and splash potion of weakness

      For recreating this on a brand new world, use this seed and traveled to the igloo basement
      Seed: 1410403532
      Coordinates: 68 74 173

      Observed Results:

      After the zombie villager has been cured, the achievement did not register

      Expected Results:

      After the zombie villager has been cured, the achievement should register

      Screenshots/Videos attached:

      Notes:
      Account used did not have the achievement before, and benchmarking was obtained so a connection to xbox live is ruled out

      Original report is below

      I have attempted and completed the requirements for the Zombie Doctor Achievement twice now and yet it hasn’t popped up yet. I am typing this one the same day as my second completion of the task. Today being the 13th of May, 2019. Allow me to go into further detail.

       

      My first attempt was on an older imported save world from the Xbox One Edition. Now on this newer Edition on the same console, with a whole NEW set of achievements to unlock. I was beyond excited to have another reason to play this game. So I’m playing, knocking out achievements left and right until I decided I wanted to Cure a Zombie Villager. So I did just that. I found then trapped a Zombie Villager so I could go and get what I needed. (Had a real tough time finding a dungeon in the Nether and getting Blaze Rods/ Blaze Powder) Made the Splash Potion of Weakness and made a Golden Apple. Went back to my captured friend. Splashed him. Then feed him the Golden Apple. Assuming I just got the achievement. I ran off to go play and get other achievements. (Starting with the one were you gotta Poison a Witch) But the Achievement never popped. This Edition has been a little glitchy where the time between completing an achievement and it actually popping is a little slow. Not too bad though. But this was at least 10-20 minutes. I even ran back to make sure he was actually cured and sure enough the now cured Cleric Villager was standing there. Surrounded by a little house of dirt. I did what I needed and yet the achievement never popped.

       

      So that was weird. Then I thought, “Maybe it was because it was an important saved world. Maybe this Achievement is bugged on these worlds?” I was trying to give the game the benefit of the doubt. So I made a whole NEW world. No imported save. Nothing special about it. Just booted it up and started anew. Once again. I got around to attempting this achievement again. But THIS time I stayed right in from of the Zombie Villager. Stared at his beady little red eyes and watched his body tremble as I watched my hard  work take it’s course. And when he transformed into a yet another Cleric Villager. The Achievement didn’t pop... again.... 

       

      As you probably know. Zombie Villagers don’t spawn very often. (Or at least not for me) And it’s really disheartening to see such hard work just go unrewarded. I love this game! And I love completing all the Achievements in this game. It’s one of my favorite things to do. I just want this fixed so I can keep doing what I like doing. Playing Minecraft. I really hope this gets worked out soon.

       

      Sincerely,

      Some Random Nerd Who Plays Video Games Way Too Much. HAHA

       

        Attachments

          Issue Links

            Activity

              People

              • Reporter:
                AKnightSenpai Alexander Knight
              • Votes:
                4 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  CHK: