Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-44726

Items - Non-full stack only swapping and not combining

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • 1.12.0.2 Beta
    • None
    • None
    • Unconfirmed
    • Android

    Description

      Hello! Just found another bug.

      Items that are not in full stack only swaps in inventory places when you try to combine them.

      However, based on the results that I got when I tried to recreate the said bug, I have observed these results:

       

      All types of inventory that needs the Inventory Window - Items in non-full stack just switched places.

      Recreatable by: Splitting items into two non-full stacks of the same item, and try to combine them inside the inventory window.

       

      Furnace -  Not smelting a non-full stack of Iron Ores even if there is a non-full stack of Iron Ingot in the output slot.

      Recreatable by: NOT RECREATABLE. It seems that it was only a bug when you just updated your world from the one created and last run on 1.11.0.3 and opened it again in 1.12.0.2. The bug behaved like it wouldn't smelt Iron Ores that is placed there in 1.12.0.2 while Iron Ingots from 1.11.0.3 is still in the Output Slot.

       

      Items not combining in a stack can be solved by any of the following. This list contains all possible methods as far as I have observed:

      1. Put items in a hopper and let it do the transferring. However, since it uses the Inventory window. you need to place the broken stack into it's 5 slots. If your items is more than 5 stacks, consider placing a chest above it and place the broken stacks inside the chest above the hopper.
      2. Drop all non-full stack of the same item, then gather them. It automatically combines them as you have claimed a single item on a floor, and combines it on the stack of the same item.
      3. When smelting, remove all contents of the furnace (if it's contents contain material smelted or created on 1.11.0.3), then wait for all of the ones in the Input Slot to get empty before putting up a new batch/stack, as they won't combine (unless a hopper supplies the Input Stack/Fuel Slot). Same with the Fuel Slot.

      If more details are needed, or if there are more parts of this bug being found, I will add them as a reply/comment on this bug.

      Attachments

        Issue Links

          Activity

            People

              SolarPH Marc John
              Votes:
              7 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: