Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-41898

Exporting MCWORLD or MCSTRUCTURE file to a OneDrive folder fails silently



    • Icon: Bug Bug
    • Resolution: Unresolved
    • 1.18.32, 1.9.0, 1.16.20, 1.16.40 Hotfix, 1.18.2 Hotfix, 1.19.2 Hotfix, 1.19.31 Hotfix, 1.19.40, 1.19.50, 1.19.51, 1.19.60, 1.19.71, 1.19.73, 1.19.80, 1.19.81 Hotfix, 1.19.83 Hotfix, 1.20.12 Hotfix, Preview, Preview, 1.20.15 Hotfix, 1.20.30
    • None
    • Confirmed
    • Windows
    • 724283


      When exporting a world or structure to a folder backed (synced) by OneDrive, the export fails silently and leaves an empty .MCWORLD or .MCSTRUCTURE file. Users can be unaware that the export failed, and this can result in the total loss of worlds if the backup was followed by deleting the world in-game to recover storage space.

      Steps to Reproduce:
      (Requires a Windows PC with access to OneDrive cloud storage)

      1. Access any world's Game settings. Scroll to the bottom and click the Export World button.
      2. In the Save As dialog, select a folder anywhere under your personal OneDrive folder. (The default path is %USERPROFILE%\OneDrive, but if you're using OneDrive to back up your Documents folder, you can select any folder under Documents in File Explorer.)
      3. Exit Minecraft.
      4. Examine the exported file in File Explorer.

      Expected Results:

      • In Minecraft, you get toast messages at the start and end of the export process.
      • In File Explorer, the exported file size is >0.

      Observed Results:

      • In Minecraft, no toast messages appear. The game just waits for you to do something else.
      • In File Explorer, the exported file size is 0.

      by Auldrick
      This problem apparently occurs only when you are exporting to somewhere in your personal OneDrive folder. If you are using OneDrive to backup your files (something you may have been encouraged to do when setting up a new PC or upgrading to Windows 11), your Desktop, Documents, and Pictures folders are probably being redirected to subfolders of the OneDrive folder and you have this problem.

      One way to work around the problem is to export the world somewhere that is not inside your OneDrive folder. You can then either use that as your Minecraft world backup folder (keeping in mind that this folder itself is not backed up to offline storage anymore), or you can use File Explorer to copy it from there to the OneDrive managed folder you're used to.

      Personally, I suggest the following technique to get as close as possible to the normal world backup process:

      1. As a one-time task, open your home folder (C:\Users\<username>) in File Explorer. Create a subfolder named "BackupTemp" there. Open the subfolder and create in it a shortcut to the folder in OneDrive where you want your backups to live.
      2. When it's time to back up a world, click Export World in the world settings (as usual) but in the Save As dialog, select the BackupTemp folder in your home folder. Then click Export to store the file. (Note that the game will remember this folder until you select a different one, so you probably only need to select it the first time.)
      3. Immediately afterword, click Export World in the world settings again. This time, the Save As dialog will show both your shortcut and the save file you just created. Drag the save file and drop it onto the shortcut to move it to your OneDrive folder, then cancel the Save As dialog. (You only clicked Export World again as an easy way to get to your BackupTemp folder, you don't need to actually save another copy.)

      The reason this technique works is that when the game exports the world save, it repeatedly opens and closes the save file (I think). That causes a problem because OneDrive is competing with it to access the file at the same time. But when you drag and drop the file, the whole file is moved in one operation and OneDrive waits until File Manager is done before trying to copy it to the cloud.

      Original description:
      After exporting, Minecraft reports export successful, but file size for exported world is 0kb. This was happening on 1.8 as well. Just updated to see if it would fix it but it has not. Did not realize last three exports failed until now, tried multiple times with current world and copy of world and tried exporting to Desktop AND backup folder just in case. World size is currently 244.5MB, but this has been happening since world was around 195 MB. 


        1. after export.png
          after export.png
          10 kB
        2. Export Fail.JPG
          Export Fail.JPG
          55 kB
        3. Hide and Seek.zip
          0.1 kB
        4. My World3 (Favorite).zip
          0.2 kB
        5. Screenshot 2022-10-28 003135.png
          Screenshot 2022-10-28 003135.png
          8 kB
        6. Screenshot 2023-04-08 102531.png
          Screenshot 2023-04-08 102531.png
          290 kB
        7. treefarm btw this is a file from structure blocks.zip
          0.2 kB
        8. when exporting.png
          when exporting.png
          182 kB
        9. World Export Error .png
          World Export Error .png
          82 kB



            SpaceMan William Money
            38 Vote for this issue
            25 Start watching this issue