Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-41625

Placing a named structure block does not automatically change it to 3D Export mode

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.9.0, 1.10.1 (Windows 10 only), 1.10.0, 1.12.0
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Windows 10 - PC

      Description

      I used to be able to place a Structure block and it would automatically change to 3D Export mode, regardless if it is named. However, in 1.9 it only works for structure blocks without names. Named structure blocks no longer automatically change to 3D Export mode.

       

      What was expected:

      When placing a Named structure block, it would change to 3D Export mode automatically and be ready when I open it

       

      The result:

      When placing a named structure block it would not change to 3D Export mode, opening it says it is in an invalid mode, and it needs to be changed to 3D Export mode by a player.

       

      Steps to reproduce:

      1. In any Creative world with cheats enabled (I had this happen in one of my Community worlds), run the command /give @p structure_block
      2. Using an anvil, name the structure block to anything you want
      3. Place the structure block, you will see the standard Structure block texture and it says "Invalid mode" when you open it

      A screenshot is attached below, and a test world can be added if needed

        Attachments

          Activity

            People

            • Reporter:
              Jonathan5733 Jonathan Hanzel
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: