Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-40538

I get stuck in end gateway but don't suffocate

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.9.0.3 Beta, 1.9.0
    • Fix Version/s: 1.11.0.3 Beta
    • Labels:
      None
    • Confirmation Status:
      Confirmed
    • Platform:
      Windows 10 - PC
    • ADO:
      175480

      Description

      I went to get the ender dragon heads that I forgot to get, and I threw an ender pearl into the gateway. My coordinates started flicking and then I got stuck in nothingness. I threw the rest of my ender pearls and ate my golden apples. I also tried placing water but I couldn't seem to place it anywhere. None of these did anything and I am currently just stuck there. I copied the world to check it out in creative, and I couldn't break any blocks or do anything. I just teleported myself back to 0 90 0 and I saw that a huge chunk of the main island was not loaded in. I rejoined the game and it came back. When I tried teleporting through again, the same thing happened.

      Additional information by [MCPE Mod] Auldrick

      When you throw an ender pearl into an end gateway that was generated in a release prior to 1.9, you get stuck in a loop teleporting between the two gateways. In many cases, your head may be trapped in the bedrock above the gateway, causing you to suffocate and die. In all cases, if you're unable to escape the gateway (which is difficult to accomplish), the rapid teleporting apparently causes an eventual renderer failure that leaves you in what appears to be a black void, This failure persists even if you're able to save and reload the world, provided you don't exit the game. When you attempt to reload the world without exiting the game, the failure to render blocks leaves the Generating World UI on the screen, creating an illusion that the game is hung.

      Possible workarounds
      Gateways generated before 1.9 will fail consistently, but new gateways should not have the problem so you can try using one generated more recently. Note, however, that due to another bug (MCPE-19699), gateways that were generated in an area where chunks already existed (because you bridged or flew there) will also have the rapid teleporting issue.

      Some people have been able to ender pearl out during the time you're flipping between the gateways. If you're able to do this, save the world, exit the game and restart it, and then load the world again. It should look normal and work normally (but the bug is still present, so don't use the gateway again).

        Attachments

        1. mcbug1.png
          mcbug1.png
          1.90 MB
        2. mcbug2.png
          mcbug2.png
          1.93 MB

          Issue Links

            Activity

              People

              • Reporter:
                Luxray997 Luke Abraham
              • Votes:
                93 Vote for this issue
                Watchers:
                43 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK: