• Type: Bug
    • Status: Resolved
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.8.0
    • Fix Version/s: None
    • Labels:
    • Confirmation Status:
    • Platform:
      Windows 10 - PC


      I created a super-flat world in creative and did /teleport @e @s, /effect @e speed 99999 255 (I don't know how many 9s there were exactly), /time set midnight, /effect @e night_vision 99999 1 (note that all these commands worked, if they don't here it is because of a typo).

      I also made witches, evokers, and villagers using spawn eggs (and gave them the effects).

      I ran away fast, then couldn't find where they were, so I did /teleport @s 1 10 0 (0 10 0 had blocks on it).

      I died many times and also came back to life with the totems of undying (but I also respawned many times).

      I set the time to day and battled mobs, but I could not hit them!

      My punches did not harm them, even though my crosshair was on them.

      I summoned iron golems to kill them and that worked.

      Then I went to creative mode and did /kill @e

      Many mobs still have the speed effect (but I did not see night vision for some reason), so they didn't die.

      I could only hurt these mobs indirectly, and I have tested these methods:

      1. Having iron golems kill them
      2. Shooting with bow and arrow
      3. Having pufferfish kill them
      4. Exploding with tnt

      I have attached screenshots of the /kill @e command not working.

      Note also that some of the mobs (some of which were the ones in the screenshots) have the speed effect, but move normally.

      Also note that I don't think the skeleton in the screenshot had the speed effect applied (or at least no particle appeared, nor did it move fast).

      Notes for the screenshots:

      In each case, I used /kill @e and the next one shows that the mobs don't die

      In #6, I wrote over a notification for security.





            Stone Stone
            0 Vote for this issue
            1 Start watching this issue