Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-170814

P2P/SIG: no_session(Expired Auth from Discovery)


    • Icon: Bug Bug
    • Resolution: Fixed
    • Preview, 1.20.10
    • 1.19.83 Hotfix, 1.20.0
    • None
    • Confirmed
    • Multiple
    • 1050649

      I've been having a recurring issue with connecting with my kid on Minecraft. We play all the time, him on our Xbox Series S, and myself on my Nintendo Switch. Both are connected to Microsoft accounts, and up until recently, we've had little to no issue connecting and playing together. He and the Xbox host, and I connect to his world with my Switch.

      The past few days, however, when trying to connect with him, I get treated to an error, specifically the one I used as the title of this post. I've Googled the error and only get Reddit posts mentioning other people experiencing it, but no actual fixes. It's been ongoing for several days and I've been awaiting word on a fix, but decided to try here.

      We're on the same Wi-Fi, of course, nothing about our setup has changed to warrant any issues. If I try to connect to the Xbox from my Switch, I get the error I mentioned. If I try to host on the Switch and have my son on the Xbox connect to me, he gets a simpler "cannot connect to world" error, with no other details. My wife has a Switch as well, and I get the simple "unable to connect to world" message with no details, no matter which one is hosting. The strange (Expired Auth from Discovery) error only occurs when my specific Switch tries connecting to the Xbox host, while any other means of connecting between the three consoles results in the simple "unable to connect to world" message.

      The issue has been ongoing for over a week and we can't play together at all, and it's been frustrating trying to figure out why.

      We've tried deleting and redownloading the game on all 3 systems. We've tried disconnecting and reconnecting pur Microsoft accounts on all 3 consoles. We've tried making several new worlds. We're all on the current 1.19.83 patch, and we do not have Realms, we only play locally. Our Wi-Fi is good, and we're all connected to the same Wi-Fi as well. We're completely and utterly confused, as we've had no issue before, and all play quite regularly together until this problem began.

      Is there any means or hope for a fix, or is it a 'wait it out' type situation?

        1. 20230524_123559.jpg
          3.30 MB
        2. 361275762_1244349886249934_8491285830989575066_n.jpg
          74 kB
        3. IMG_2104.jpeg
          1.71 MB
        4. IMG_2166.jpeg
          2.85 MB

            TravinoEXE TravinoEXE
            16 Vote for this issue
            18 Start watching this issue