Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-145809

Some command blocks stop providing outputs if their delay in ticks is set too high

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • 1.17.40
    • None
    • None
    • Creative
    • Unconfirmed
    • Multiple

    Description

      DESCRIPTION: Some command blocks do not execute their command, and their "previous output" dialog box does not update either. 

      EXPECTED RESULT: The command should be successful, and otherwise a failure message should have been shown.

      HOW TO REPRODUCE: Place a command block and insert a command. Set the "Delay in Ticks" at a high value (higher than 30, in my experience on Switch). Activate the command block. After waiting for the delay to finish, nothing will happen.

       

      Concerning the bugged blocks, if you previously used them in the past and their previous output is shown, then you will keep seeing that successful output message forever, even if you repeatedly power the command block afterwards with no success (you would expect a failure message at least). If you toggle "Previous Output" off and then put it back on again, now the dialog box will always show "-" instead.

      So far, the bug has been encountered on both Switch and Windows 10. Huge thanks to user Ryan Scott for the discovery of the cause of the bug (the delay value)! Previously, I failed to understand why some command blocks worked while others did not, as I overlooked that factor.

      Attachments

        Issue Links

          Activity

            People

              Gwyddolf_Carthnap Gwydolf Carthnap
              Votes:
              17 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: