Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-132700

Custom Blocks do not load if the register_to_creative_menu attribute is set

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Resolution: Duplicate
    • 1.17.10.23 Beta, 1.17.2 Hotfix
    • None
    • None
    • Unconfirmed
    • Multiple

    Description

      All registered custom blocks in the creative menu fail to load with the following issue.

      [Blocks][error]-block_definitions | C:/Users/%USER%/AppData/Local/Packages/Microsoft.MinecraftUWP_8wekyb3d8bbwe/LocalState/games/com.mojang/minecraftWorlds/NM5DXvP4AAA=/behavior_packs/FC_B | blocks/block_acacia.json | description | register_to_creative_menu | child 'register_to_creative_menu' not valid here.

      [Blocks][error]-block_definitions | C:/Users/%USER%/AppData/Local/Packages/Microsoft.MinecraftUWP_8wekyb3d8bbwe/LocalState/games/com.mojang/minecraftWorlds/NM5DXvP4AAA=/behavior_packs/FC_B | blocks/block_acacia.json | Failed to verify block

       

      We've attached the block file from this add-on, and I've found a workaround to keep it running till it's fixed.

      The blocks will load and work properly if the property "register_to_creative_menu" is removed from the description. (They will not be available in the creative menu, but they will be available for /give commands and everything else.)

      We hope this is rectified fast because it makes testing custom blocks much more difficult.

      Attachments

        Issue Links

          Activity

            People

              Kaomc_ Kao
              Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: