Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-12420

Redstone dust not powering the correct blocks

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 0.13.0
    • Fix Version/s: 0.14.2
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      Phone - iOS - iPhone 5S

      Description

      Well actually I'm using 0.13.1 but there isn't this option.
      In MCPE, a redstone dust "connected to nothing" automatically points to all four adjacent blocks, but in my pictures some adjacent blocks which are pointed to doesn't seem to be actually powered.
      To reproduce this situation, place a redstone dust pointing to a block in any direction. As the world is made of blocks, now there is a row of blocks in which both the block and the redstone dust is in the row. Power the redstone dust with a block or a redstone torch which is adjacent to the redstone dust but is out of that row. Test if the first block (pointed by the wire) is powered and you will find that it is not.
      I'm afraid this can't be explained clearly so in the screenshots below there are several situations in which the bug occurs.
      The bug happens in different directions, so I wonder if the code about checking which directions a redstone dust points to is incorrect.

        Attachments

        1. IMG_1718.PNG
          533 kB
          TRCYX
        2. IMG_1720.PNG
          565 kB
          TRCYX
        3. IMG_1721.PNG
          560 kB
          TRCYX
        4. IMG_1722.PNG
          318 kB
          TRCYX

          Issue Links

            Activity

              People

              Reporter:
              TRCYX TRCYX
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: