Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-111632

Cloned moving blocks do not revert to regular blocks

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Resolution: Unresolved
    • Affects Version/s: 1.17.10.22 Beta, 1.17.10.21 Beta, 1.17.10.20 Beta, 1.17.0.58 Beta, 1.17.0.56 Beta, 1.17.0.52 Beta, 1.17.0.50 Beta, 1.16.230.56 Beta, 1.16.230.54 Beta, 1.16.230.52 Beta, 1.16.220, 1.16.220.52 Beta, 1.16.220.51 Beta, 1.16.220.50 Beta, 1.16.210.61 Beta, 1.16.210.60 Beta, 1.16.210.59 Beta, 1.16.210.58 Beta, 1.16.210.57 Beta, 1.16.210.56 Beta, 1.16.210.55 Beta, 1.16.210.54 Beta, 1.16.210.51 Beta, 1.16.201 Hotfix, 1.16.210, 1.16.221 Hotfix, 1.17.0
    • Fix Version/s: None
    • Confirmation Status:
      Confirmed
    • Platform:
      Multiple
    • ADO:
      461692

      Description

      Updated description by [Mod] GoldenHelmet

      Steps to reproduce

      1. Set up two pistons on a fast clock circuit pushing a row of blocks back and forth between them.
      2. Clone the contraption to a new location.
      3. Repeat step (2) until the row of blocks between the pistons get cloned as moving blocks rather than the original blocks.

      Expected result

      One of the following

      • You never get cloned moving blocks in step (3), or
      • The cloned moving blocks in step (3) are linked to the cloned pistons.

      Actual result

      The cloned moving blocks are linked to the original pistons from step one, i.e. the /clone command copies exact tile entity data instead of relative tile entity data. When you activate the original pistons, the cloned moving blocks animate, and when you break the original pistons, the cloned moving blocks revert to their parent block type.

      Note

      Based on the original report and world save, it might be possible to reproduce this during chunk loading rather than cloning, perhaps with moving blocks being pushed across a chunk border, but I was not able able to do so in brief testing.


      Original summary
      When piston pushed block isn't rendered causes stuck pushing or pull when many block while loading the world.
      Original description
      When piston pushed block isn't rendered when loading the world causes it stuck push and pulling block or when you traveling too far cause it will not rendered redstone is running for piston is pushing loopily.

        Attachments

          Issue Links

            Activity

              People

              Reporter:
              Junior5a Junior Apanishile
              Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: