Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-103691

Repeaters are not applying correct delay and appear as though they do

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: 1.16.50 Hotfix (iOS)
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed
    • Platform:
      iOS

      Description

      1. Set up 2 lines of redstone dust coming from the same lever and going to 2 different trapdoors (not lamps because lamps have delay before they turn off)
      2. On one line, put a repeater without changing the delay and keep the other line just dust
      3. Observe the way pattern of the redstone lighting up and when the trapdoors activate.

      When you flick the lever, both trapdoors will activate simultaneously, and the redstone dust line following the repeater will appear to activate with one tick of delay, however, it activates 1 tick before it lights up. (The repeater could also be applying delay incorrectly on higher delay settings and could be on multiple platforms, but I have no way of testing that currently)

      The side with the repeater should activate 1 tick after the side clear side and The redstone dust following the repeater should visually and light up and activate at the same time as the repeater.

        Attachments

          Issue Links

            Activity

              People

              Reporter:
              Loaf of Pain Aidan Walter
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: