Uploaded image for project: 'Minecraft (Bedrock codebase)'
  1. Minecraft (Bedrock codebase)
  2. MCPE-100700

Custom Biomes no longer generate

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.16.200.57 Beta, 1.16.200.56 Beta, 1.16.200.55 Beta, 1.16.200.53 Beta, 1.16.200.52 Beta, 1.16.200.51 Beta, 1.16.100.60 Beta, 1.16.100.58 Beta, 1.16.100.57 Beta, 1.16.100.56 Beta, 1.16.100.59 Beta, 1.16.100
    • Fix Version/s: None
    • Confirmation Status:
      Confirmed
    • Platform:
      Multiple
    • ADO:
      424610

      Description

      Custom biomes that were working before no longer work in the beta, also attempting to transform existing biomes into new biomes crashes the game.

      All of the new experimental features are turned on.

      Update:

      • After more trial and error; you can overwrite vanilla biomes but the crash occurs when attempting to use custom biomes as a transformation (hills, river, mutate, etc.)
      • When the crash occurs, the following error comes up in the content log;
        • 17:07:21[BiomeRegistry][error]-My World | biomes_server | forest | minecraft:overworld_generation_rules | hills_transformation | giga_hills is not a valid biome

      Update - 1.16.200.55:

      • In this update custom biomes will no longer crash the game and will be findable in a world, however:
        • Once the world is unloaded and reloaded, custom biomes and features will no longer generate
        • A crash has occurred shortly after loading into a new world and moving around while custom biomes generate

      Expected Behavior:

      • Custom biomes generate in worlds and transforming vanilla biomes into custom biomes doesn't crash the game.

      Actual Behavior:

      • Game crashes or biomes simply don't appear

      Steps to Reproduce:

      1. Download and install the attached pack
      2. Create a new world with experimental features on and the behavior pack active
      3. The game will crash with the error log above
      4. Go to the forest.json file in the biomes folder and remove the line:  ["giga_hills", 3] from the file and create another world using the above steps.
      5. The world will load but the biome will be nowhere to be found

       

        Attachments

          Issue Links

            Activity

              People

              Reporter:
              Gruntastic Gruntastic
              Votes:
              20 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: