Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-8649

Linux: "Missing key 'natives-linux' on libraries[*].downloads" when downloading versions 1.8 and lower

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 2.0.1003 (Windows)
    • Labels:
    • Environment:
    • Confirmation Status:
      Community Consensus

      Description

      Trying to download the client for 1.8.x with the 2.0.1005-dev-linux client fails with the error message.

      Error details: Missing key 'natives-linux' on libraries[*].downloads (should be object, required as there's a classifier)

      No 1.8 folder is created under versions, and no jar files are downloaded.

      Newer versions 1.9 - 1.12.2 all seem to work fine, but can not download and launch a 1.8.x client for regression testing.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peterix [Mojang] Petr Mrázek
                Reporter:
                klugemonkey David Chamberlin
              • Votes:
                3 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  CHK: