Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-1672

OS X: Minecraft cannot download

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 1.2.7, 1.2.8, 1.3, 1.3.1
    • Fix Version/s: 1.3.3
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OSX

    • Confirmation Status:
      Unconfirmed

      Description

      Razinao added a comment - 26/Oct/13 1:52 PM

      I too had this error. After navigating to Users/username/Library/Java/Extensions and moving xerces.jar to the trash, the launcher was able to properly download the update.


      What I expected was the launcher to
      either download the remaining files or just open minecraft (it didn't even get past the Launcher).
      the bin is also missing as far as I'm aware.
      what ended up happening was: The loading bar was full, the report got up to: "Libraries': Used own copy as it matched etag
      Job 'Version & Libraries' finished successfully" and the launcher just stopped launching. It should be also noted that I have:
      1. re-downloaded minecraft
      2. deleted the original directory/renamed it
      3. reopened it several times

      steps to reproduce the bug:
      1. Open the launcher
      2. click play
      3. it just loads then stops before the actual thing loads

      note: it started when I received the 13w42a snapshot. and hasn't stopped since.


      Unhandled exception in executor net.minecraft.launcher.updater.ExceptionalThreadPoolExecutor$ExceptionalFutureTask@3bd85e85
      java.util.concurrent.ExecutionException: java.lang.AbstractMethodError: org.apache.xerces.dom.DeferredElementImpl.getTextContent()Ljava/lang/String;
      	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
      	at java.util.concurrent.FutureTask.get(FutureTask.java:83)
      	at net.minecraft.launcher.updater.ExceptionalThreadPoolExecutor$ExceptionalFutureTask.done(ExceptionalThreadPoolExecutor.java:54)
      	at java.util.concurrent.FutureTask$Sync.innerSetException(FutureTask.java:273)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:307)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.AbstractMethodError: org.apache.xerces.dom.DeferredElementImpl.getTextContent()Ljava/lang/String;
      	at net.minecraft.launcher.updater.VersionManager.getResourceFiles(VersionManager.java:283)
      	at net.minecraft.launcher.updater.VersionManager.downloadResources(VersionManager.java:236)
      	at net.minecraft.launcher.Launcher$1.run(Launcher.java:156)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	... 4 more
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                HowAboutNo Luka Wolfhaus
              • Votes:
                4 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: