Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-1421

Selecting Alpha 1.2.0 version launches Alpha 1.2.0_02 instead

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Invalid
    • Affects Version/s: 1.2.1, 1.6.76 (java), 2.0.1003 (Windows), 2.0.1049 (Windows), 2.1.1216 (Windows) / 2.1.1217 (Mac OS) / 2.1.1218 (Linux), 2.1.2480-2.1.2482
    • Fix Version/s: 1.2.1
    • Component/s: Java Edition Versions
    • Labels:
    • Environment:
      Debian Linux Wheezy (7) 3.2.0-4-amd64 SMP kernel
      Oracle Java 1.7.0_25 64-bit
    • Confirmation Status:
      Confirmed

      Description

      NOTE: THIS IS NOT AN ISSUE WITH THE OLD VERSION OF THE GAME SPECIFICIALLY. THIS IS BECAUSE THE VERSION OF THE GAME IN QUESTION IS MISLABELLED ON THE MOJANG SERVERS AND ALSO THE LAUNCHER AS A RESULT. This ticket may be moved the the WEB project if more applicable.

      When I was trying out the new launchers recent support for alpha and earlier versions of Minecraft, I was trying to try out the first version I ever used, Alpha 1.2.0. In the drop-down there is the 3 versions of Alpha 1.2.0: 1.2.0, 1.2.0_01 and 1.2.0_02. When trying to pick plain 1.2.0 the launcher gives no indication of an error and proceeded to launch, however the version launched reports 1.2.0_02 in game.

      Picking Alpha 1.2.0_01 behaves correctly and launches 1.2.0_01, and same with picking Alpha 1.2.0_02, it launches Alpha 1.2.0_02 correctly.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Awesoman3000 Connor Steppie
              Votes:
              6 Vote for this issue
              Watchers:
              11 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                CHK: