Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-13293

Debian package, dependency problem

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 2.1.12466
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed

      Description

      Current Debian package lists libpango1.0-0 (>= 1.14.0) as dependency for the minecraft-launcher. I'm using Buster and this package now is transitional, replaced by libpango-1.0-0, libpangocairo-1.0-0, libpangoft2-1.0-0, libpangox-1.0-0 and libpangoxft-1.0-0. Moreover, it breaks dependencies with upcoming packages.

      I guess it's safe to change "libpango1.0-0 (>= 1.14.0)" dependency for a conditional of the form "libpango1.0-0 (>= 1.14.0) | libpango-1.0-0 (>= 1.14.0)" keeping it compatible with existing setups and newer.

      Thanks!

        Attachments

          Activity

            People

            Assignee:
            peterix [Mojang] Petr Mrázek
            Reporter:
            slacuesta Sebastián Lacuesta
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: