Uploaded image for project: 'Minecraft Launcher'
  1. Minecraft Launcher
  2. MCL-12570

Versions which inherit and re-define a library cause corrupted downloads

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 2.1.9616-2.1.9618, 2.1.10835-2.1.10837
    • Fix Version/s: None
    • Component/s: Minecraft Launcher
    • Labels:
    • Confirmation Status:
      Community Consensus

      Description

      Potential fixes
      • Download the file that's said in the "URL" and place it in the folder identified by "Path"
      • Run the vanilla version of the game for that version, then run the modded version.

      If you need additional help, please contact 💬 Community Support.

      Attempting to use the following json as a version (provided by Minecraft Forge) results in several files being corrupted on their download which results in their hashes being invalid.

      If a library is defined as required in the root version and a version json inherits from it and re-declares the library, the file downloads improperly and fails to launch. 

      If an item is declared as a library in both 1.12.2 and a child, then it seems this behavior occurs. This also has occurred with 1.7.10 Forge files.

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                Lord_Ralex Lord_Ralex
              • Votes:
                17 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK:

                  Potential Duplicates