Uploaded image for project: 'Minecraft Console Edition'
  1. Minecraft Console Edition
  2. MCCE-3983

[X360 - TU48] Achievements not unlocking/locked after not syncing with the servers.

    XMLWordPrintable

    Details

    • Affected Platforms:
      Xbox 360

      Description

      The achievements in the latest update were buggy the first few hours after the update came out. You could download and play with the new content like normal and earn achievements, but the achievements did not track and sync to the servers, resulting in problems at the moment!

      I started by downloading the update. As soon as I unlocked some new achievements in Tumble, I noticed that the counter remained at 62/62 unlocked achievements and the Gamerscore had not moved from 1360. I unlocked a few more, but none of them got applied to my profile.

      A few hours later and the update went "live" fully, along with the achievements. Now the achievement list is expanded to 62/80 like it should. My Xbox however already thinks I've got 72/80 at this point in time (but these 10 achievements don't show up in my activity feed, on my achievement list when friends visit my profile or on TrueAchievements after a scan).

      The problem here (I think) is that my Xbox console thinks I unlocked the achievements, but it never synced them to the Xbox servers because I unlocked them while the achievements for the update weren't completely live yet (while the update was playable before the achievements got added to the Xbox servers).

      I decided to delete my profile and re-download it. The 10 achievements got locked again, no big deal. Here is where the problem comes in: I can now only unlock the achievements that I DID NOT earn before the update went live. If I try to re-unlock any of the 10 achievements I unlocked before the update (and it's achievements) launched properly, they won't seem to unlock again. I tried deleting profile, clearing cache, trying on a different console. Nothing seems to work.

      I'm not the only person affected by this. So far I've seen 1 Minecraft Forums post about it and 15+ people having it on TrueAchievements. This also seems to have happend with a previous update, so I hope the Team knows what I'm talking about here!

      Thank you so much for reading! If you need any more information to investigate the issue, be sure to let me know!

      EDIT:
      I just found a way around this bug. If you follow these steps you should be able to unlock the achievements! This has worked for quite a few people so far. If it doesn't work for you, please leave a comment down below so we can figure out what went wrong!
      1. Start up the Xbox (it auto signed in for me).
      2. Manually sign out of your profile on the Xbox dashboard.
      3. Launch Minecraft.
      4. Press Play Game
      5. A popup appears and asks you to sign in. Press Yes [I want to sign in].
      6. The achievements popped right away on the world selection screen.

      This still means 4J Studios need to fix this. There are loads of people affected by this bug that do not visit this site every day. They are still in need of a propper fix!

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Karrecod Karrecod
            • Votes:
              5 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: