Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-96224

Activated detector rails moved by pistons do not update redstone correctly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 16w04a, Minecraft 16w41a, Minecraft 1.11.2, Minecraft 1.12, Minecraft 1.12.1, Minecraft 1.12.2, Minecraft 17w43a, Minecraft 17w43b, Minecraft 17w48a, Minecraft 1.13-pre3, Minecraft 1.13-pre6, Minecraft 1.13-pre7
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Confirmed
    • Category:
      (Unassigned)

      Description

      See attached screenshots. A detector rail that was powered and then moved into a spot where it should be powering the redstone dust underneath did not update the redstone dust after being moved. Only after updating the redstone dust by placing a block next to it did it power up.

      Likely also affects similar configurations where the powered component (dust in this case) doesn't receive a block update after moving the rail.

        Attachments

        1. 2016-01-28_22.34.25.png
          885 kB
          [Mod] redstonehelper
        2. 2016-01-28_22.34.29.png
          752 kB
          [Mod] redstonehelper
        3. 2016-01-28_22.34.35.png
          867 kB
          [Mod] redstonehelper
        4. 2016-01-28_22.34.45.png
          676 kB
          [Mod] redstonehelper

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                redstonehelper [Mod] redstonehelper
              • Votes:
                6 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK: