Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-92761

Game Crash with Falling Sand and Stone Buttons

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 15w46a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
    • Confirmation Status:
      Unconfirmed

      Description

      This is a very odd, reproducable bug that seems to have something to do with redstone power updates. I have seen other bug reports that crash with the same error but none show reproduction steps so I will post this one.

      Steps to reproduce.

      • Create a new superflat 15w46a world
      • Place an impulse command block down with space above it and enter the following command:
        summon FallingSand ~ ~.5 ~ {Block:minecraft:activator_rail,DropItem:0,Time:1}
      • Power the command block directly by placing a stone button on its side and clicking it.

      Result

      The game will crash and give the attached crash report. On re-opening the world the activator rail will be placed on top of the command block and appear to be powered.

      Things I've tried

      • The game does NOT crash if a lever or redstone block is used in place of a button
      • The game sometimes crashes if a stone block is placed next to the command block and a button powers the command block indirectly through the stone. I haven't worked out ways to reproduce the crash with this setup but it happened the first time I tried it.
      • The game does NOT crash if a fallingsand entity with a Block value of stone is summoned instead of an activator rail.
      • Summoning the fallingsand so it lands on top of a stone block elsewhere in the world that is being powered by a stone button at the moment the sand lands also crashes the game

      On a side note, the activator rail appears to remain on once the power has been removed until it receives a block update.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sparks Sparks
              • Votes:
                5 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: