Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-84199

Could not join the server created using old world file.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 15w31a, Minecraft 15w31b
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      WIndows 7 64-bit operating system.
      Java version : Version 8 Update 51 , (build 1.8.0_51-b16)
    • Confirmation Status:
      Unconfirmed

      Description

      I created a server with my old world on version 15w31a but failed to join and this shows up:
      Internal Exception: io.netty.handler.codec.DecoderException: com.google.gson.JsonSyntaxException: com.google.gson.stream.Malformed.JsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 1

      The world had no problem when being opened in server of version 1.8 onwards and was able to join.

      Steps to reproduce:
      1)Put the world file in server folder.
      2)Open the server with that world file.

      *Note: The region file in the world folder is too huge so i split it into 4.
      I am not sure that this issue could be open to public because it contains private informations.

        Attachments

        1. MC bug 1.jpg
          MC bug 1.jpg
          115 kB
        2. MC bug 2.jpg
          MC bug 2.jpg
          88 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                LLS123 Lee Li Sheng
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: