Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-82464

Colored 'dead' skin template parts cause in-game issues

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 1.8.7, Minecraft 1.8.8, Minecraft 15w46a, Minecraft 1.9.1, Minecraft 1.9.2
    • Labels:
      None
    • Environment:
      PC Windows 7
    • Confirmation Status:
      Community Consensus

      Description

      The 'dead' parts in the new 1.8 skin template appear to cause issues in-game. In my attachments I made clear which areas I mean by 'dead' parts by coloring them bright red.

      People who have these parts colored, get 'messed up' skins in game. By which I mean that parts of the 3D layer are turned off while they shouldn't be, or things are visible that shouldn't be.

      How to reproduce: fist upload a skin to your minecraft account without these 'dead' parts being colored and see if it's working properly. Then color the dead parts and upload the skin to your minecraft account again. The same symptoms should appear.

      I found this out while helping people out with their skins on the MC forums. People said to have found no issues in their skin template, but then did have issues with their skin in-game. After I removed all the colors in the 'dead' areas of the skin, the issues were resolved.
      The issues that appear in-game, don't appear in the minershoes, novaskin and MCskin3D 3D previewers.

      I hope I am the first one pointing this out, I couldn't find similar reports. Would be great if this problem could be solved!

      Edit:

      Many skin editors make it so that the 'dead' parts can be colored. Especially less experienced skin makers may accidentally color these parts, which will result in a messed up look of the skin in-game. More experienced skin makers use these parts to make color palettes and signatures in. This is why these parts shouldn't bug the skins in-game.
      Here is a screenshot of a skin without the 'dead' parts colored in game: (front) http://i.imgur.com/VypXSgl.png (back) http://i.imgur.com/x8s9mI5.png
      Here is a screenshot of that same skin with some of the 'dead' parts being colored: (front) http://i.imgur.com/W71cLHP.png (back) http://i.imgur.com/4nymVCt.png
      Here are the skins I used to test this: (no bug) http://i.imgur.com/1Lj8ZL3.png (bug) http://i.imgur.com/U9x7Uc5.png
      Note that in these screenshots all the 3D parts are turned ON in the menu. They bugged away, I didn't turn them off manually.
      You can use these skins to recreate the issue.

      During my attempt to recreate the issue, I found out that there are some more conditions to the bug occurring.

      • The 3D part has to be ENTIRELY colored, so a part such as 'jacket' or 'right arm'
      • The colored 'dead' part has to be next to the bugging 3D part in order to cause the bug. If the dead parts around the 3D part aren't colored, nothing will go wrong.
        I recreated these conditions in my screenshots.

      Oddly enough, the 'dead' parts seem to bug the skins in other ways too, such as the dead parts appearing on the skin either way. Like in this forum topic: http://www.minecraftforum.net/forums/mapping-and-modding/skins/2469064-what-have-i-done-wrong

      I think it is a major bug, I've seen 3 people on the minecraft forums skin section complain about similar issues within 1 day.
      As additional information, the bug seems to only be caused by the 'dead' parts in the section of the skin template that's new to 1.8 skins. The 'old' dead parts don't cause problems (as you can see, I used them for a signature and color palettes in my first attachment).

      These are the forum topics I am referring to: http://www.minecraftforum.net/forums/mapping-and-modding/skins/2476570-having-skin-issues
      http://www.minecraftforum.net/forums/mapping-and-modding/skins/2469064-what-have-i-done-wrong
      http://www.minecraftforum.net/forums/mapping-and-modding/skins/2477455-help-me-with-my-skin-please

      To fix this bug, it must be made impossible for the 'dead' parts in the skin template to affect the in-game look of the skin in any way.

      I hope I made it clear that this is in fact a problem, and that I provided enough information for you to recreate and fix this issue.
      Please let me know what happens

        Attachments

        1. bug-back.png
          bug-back.png
          176 kB
        2. bug-front.png
          bug-front.png
          211 kB
        3. example.png
          example.png
          41 kB
        4. no-bug-back.png
          no-bug-back.png
          255 kB
        5. no-bug-front.png
          no-bug-front.png
          180 kB
        6. skin-bug.png
          skin-bug.png
          3 kB
        7. skin-no-bug.png
          skin-no-bug.png
          2 kB

          Issue Links

            Activity

              People

              • Assignee:
                ProfMobius [Mojang] ProfMobius (Thomas Guimbretiere)
                Reporter:
                DinowCookie_ Desirée Blaauw
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  CHK: