Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-54842

@e selector cannot find villagers in "old" 1.7.x worlds

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Incomplete
    • Affects Version/s: Minecraft 14w18b, Minecraft 14w19a, Minecraft 1.8.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Server: MineOS VM 8GB RAM
      Clients: Windows 7 x64 8GB RAM
      Debian 7 x64 4GB RAM

      Latest Java 7 on all systems

      SMP World
    • Confirmation Status:
      Community Consensus

      Description

      Using the command /testfor @e[type=Villager,r=10] results 10 lines saying 'That entity cannot be found' when there are clearly 10 villagers in front of me. See the image below.

      I expect the command return 10 lines saying 'Found Villager'.

        Attachments

        1. 2014-05-08_16.05.52.png
          2014-05-08_16.05.52.png
          184 kB
        2. 2014-05-08_16.51.57.png
          2014-05-08_16.51.57.png
          195 kB
        3. 2014-05-08_22.17.01.png
          2014-05-08_22.17.01.png
          224 kB
        4. 2014-05-08_22.17.02.png
          2014-05-08_22.17.02.png
          124 kB
        5. 2014-08-11_01.05.18.png
          2014-08-11_01.05.18.png
          97 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              matrixhacker Michael Turner
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                CHK: