Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-33558

Agro tags don't work with Neutral Mobs that have New AI

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 1.5.2, Minecraft 1.6.2, Minecraft 1.6.4, Minecraft 13w39a, Minecraft 13w39b, Minecraft 13w41a, Minecraft 1.7.4, Minecraft 14w08a, Minecraft 1.7.5, Minecraft 14w10b, Minecraft 1.7.9, Minecraft 14w20b, Minecraft 14w21a, Minecraft 14w21b, Minecraft 1.7.10-pre1, Minecraft 14w25a, Minecraft 14w25b, Minecraft 14w26b, Minecraft 14w26c, Minecraft 14w28a, Minecraft 14w28b, Minecraft 14w29a, Minecraft 14w29b, Minecraft 14w30c
    • Fix Version/s: Minecraft 14w31a
    • Labels:
      None
    • Environment:

      Windows 7 Home Premium, 16GB RAM, Core i7 3770k, and Java 7 (latest)

    • Confirmation Status:
      Confirmed

      Description

      EDIT: It appears that the cause leads to the New AI. Wolves already had the New AI before Pigmen did and the bug was only for wolves when this was created, because the anger tag for Pigmen still worked. Since 14w06, the anger tag no longer works for Pigmen, which leads it to the New AI because Jeb made all mobs have the new AI now.

      Steps to Reproduce:
      1.8/1.7 - type

      /summon Wolf ~ ~ ~ {Angry:1}
      /summon PigZombie ~ ~ ~ {Anger:1}
      

      [Mojang] Jeb (Jens Bergensten) added a comment - 30/Jul/14 2:08 PM

      This has been fixed, but differently for wolves and zombies:

      Wolves will only remain angry as long as they have something to attack. Summoning an angry wolf will immediately make it non-angry since it doesn't have a target.

      Pig Zombies will actively try to find targets for as long as they're angry, even if they can't find / don't know the source of the anger.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jeb [Mojang] Jeb (Jens Bergensten)
                Reporter:
                kazblox kazblox
              • Votes:
                13 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  CHK: