Minecraft
  1. Minecraft
  2. MC-2912

Creative Mode Hotbar Glitch when using Number Key to exchange items slots

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 1.4.2, Minecraft 1.4.4, Snapshot 12w50a, Minecraft 1.4.6, Minecraft 1.4.7, Snapshot 13w09a, Snapshot 13w09b, Snapshot 13w09c, Minecraft 1.5, Minecraft 1.5.1, Minecraft 1.5.2, Minecraft 1.6.1, Minecraft 1.6.2, Minecraft 1.6.4, Minecraft 13w42b, Minecraft 13w43a, Minecraft 1.7.1, Minecraft 1.7.2, Minecraft 1.7.4, Minecraft 14w02c, Minecraft 14w03b, Minecraft 14w04a, Minecraft 14w04b, Minecraft 14w05a, Minecraft 14w05b, Minecraft 14w08a, Minecraft 1.7.5, Minecraft 14w10c, Minecraft 14w11b, Minecraft 1.7.6-pre1, Minecraft 1.7.6-pre2, Minecraft 1.7.9, Minecraft 14w17a, Minecraft 14w18b, Minecraft 14w21b, Minecraft 14w25a, Minecraft 14w25b, Minecraft 1.7.10, Minecraft 1.8, Minecraft 1.8.1-pre4, Minecraft 1.8.1, Minecraft 1.8.2-pre1, Minecraft 1.8.3, Minecraft 1.8.4, Minecraft 1.8.5, Minecraft 1.8.6, Minecraft 1.8.8, Minecraft 15w32b, Minecraft 15w32c, Minecraft 15w34a, Minecraft 15w34b, Minecraft 15w35b, Minecraft 15w36d, Minecraft 15w37a, Minecraft 15w39b, Minecraft 15w40b, Minecraft 15w41b, Minecraft 15w42a, Minecraft 15w43b, Minecraft 15w43c, Minecraft 15w44a, Minecraft 15w44b, Minecraft 15w45a, Minecraft 15w46a, Minecraft 15w47a, Minecraft 15w47c, Minecraft 15w49b, Minecraft 1.8.9, Minecraft 15w51b, Minecraft 16w06a, Minecraft 1.9 Pre-Release 1, Minecraft 1.9 Pre-Release 2, Minecraft 1.9.1, Minecraft 1.9.2, Minecraft 1.9.4, Minecraft 16w20a, Minecraft 16w21a, Minecraft 16w21b, Minecraft 1.10 Pre-Release 1, Minecraft 1.10, Minecraft 1.10.2, Minecraft 16w32a, Minecraft 16w32b, Minecraft 16w33a, Minecraft 16w35a, Minecraft 16w38a, Minecraft 16w39b, Minecraft 16w40a
    • Fix Version/s: Minecraft 16w41a
    • Security Level: Minecraft - Public (Viewable by everyone)
    • Environment:

      OS: Windows XP Build 2600 Service Pack 3,
      OS: Windows 8, Java: 1.7.0_51

    • Confirmation Status:
      Confirmed
    • Game Mode:
      Creative

      Description

      In creative mode, when I place a water bucket (for example) in Hotbar slot, hover above it and press a numberkey to move the it (i.e. to swap it with a dirt block) and then place the water bucket (which is now where the dirt block was and vice versa), it will place dirt. Not water. Placing dirt works as expected. Also works vice versa.

      Steps to reproduce:

      Example using water bucket
      1. Put a water bucket in your hotbar. (i.e. 1st slot)
      2. Press any number key (1-9) while hovering over water bucket, except its own slot number. (In this case 1.) Example : Dirt is in 2nd slot so press '2' and swap dirt and water bucket.
      3. Place water bucket.
      4. Water bucket is seems to be placed and is instantly replaced by dirt.
      5. Open inventory to fix problem. If you are holding the water bucket in your hand it will be animated as if it was beeing swapped.

      This apparently happens with all blocks. I haven't fully tested yet. It also works with having nothing instead of dirt, then water is placed for a short moment and instantly replaced by air. Also works with potions.


      Code analysis by [Helper] Marcono1234 can be found in this comment

        Issue Links

          Activity

          [Helper] Fabian Röling added a comment -

          Number keys exchange slots. That's what this bug is about. 1, 2, 3 and 4 are number keys.
          I just tested and was able to duplicate/delete so much that 3 of 4 slots contained the same item at the end.

          [Mod] Neko added a comment -

          Also cannot reproduce. [Helper] Fabian Röling, does MC-341 describe your issue?

          [Helper] Fabian Röling added a comment -

          Ok, apparently this is fixed. I was confused by buggy weirdness.
          I can't confirm the fix myself, because apparently this is something I never encountered. But if other people say that this is fixed, it apparently is.

          HalfOfAKebab added a comment -

          I think this bug has returned in as a deadlier strain, so to speak. Since around 16w40a, I've experienced (albeit rarely) a similar bug in survival. Here's a video I stumbled across of this bug occuring: https://www.youtube.com/watch?v=Oupg58gOiZk (skip to 21:49s). This could possibly be a very detrimental bug, as, as you can see in the video, the block you're trying to place is consumed despite not being placed, and the block that is actually placed is not consumed. If this could be consistently reproduced, this could be a very bad duplication bug. For example, we could "try" to place a block of dirt and instead have a block of diamond placed, with the dirt being taken from the hotbar and the block of diamond not, basically turning dirt to diamond.

          [Mod] Neko added a comment -

          HalfOfAKebab, that looks like MC-5694.


            People

            • Assignee:
              [Mojang] Agnes Larsson
              Reporter:
              LBBO
            • Votes:
              38 Vote for this issue
              Watchers:
              27 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                CHK: