Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-231984

The "Don't forget to back up this world before you load it in this snapshot." warning appears on a world created with a version before 1.18 Experimental Snapshot 1, despite the world saying "Created by an incompatible version"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Invalid
    • Affects Version/s: 1.17.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      macOS Big Sur 11.4, Java Version 16.0.1
    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      The site won't let me choose 1.18 Experimental Snapshot 1 as affected, so I chose 1.17.1.

      The bug

      Even though worlds created in versions before 1.18 Experimental Snapshot 1 can't be loaded in 1.18 Experimental Snapshot 1, the "Don't forget to back up this world before you load it in this snapshot." warning still affects worlds created in versions before 1.18 Experimental Snapshot 1.

      How to reproduce:

      1. Drag a world created in a version before 1.18 Experimental Snapshot 1 in your saves folder.

      2. Notice how it says "Don't forget to back up this world before you load it in this snapshot." even though the world can't be loaded in 1.18 Experimental Snapshot 1

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            rjakobs Robert Jakobs
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: