Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-229824

Debug log getting spammed with Invalid biome data received, starting from 0: when using a custom biome settings in a buffet world

    XMLWordPrintable

Details

    • Bug
    • Status: Open
    • Resolution: Unresolved
    • 1.17, 1.17.1 Pre-release 1, 1.17.1 Pre-release 2, 1.17.1 Pre-release 3, 1.17.1 Release Candidate 1, 1.17.1, 21w37a, 1.18 Pre-release 4, 1.18 Pre-release 5, 1.18 Pre-release 6, 1.18 Pre-release 7, 1.18 Pre-release 8, 1.18 Release Candidate 1, 1.18 Release Candidate 2, 1.18 Release Candidate 3, 1.18, 1.18.1 Pre-release 1, 1.18.1 Release Candidate 1, 1.18.1, 22w07a, 1.19
    • None
    • None
    • Confirmed
    • Debug, World generation
    • Normal

    Description

      When using a custom biome, custom feature, or custom carver and using it in a buffet world the game starts spamming the debug log with Invalid biome data received, starting from 0: -1, -1, etc.
      The game started getting laggy and would probably get unplayable.
      Steps to reproduce
      1. Download provided data pack or any data pack that uses custom biomes.
      2. Add data pack to a world and create a world that is a single plains biome world or is a custom biome/ uses custom settings.
      3. Watch the error log and notice that the biome is ocean instead of plains or whatever the custom biome is.

       

      Currently unable to test because of MC-237275

      Attachments

        1. 2021-06-21_08.44.32.png
          2021-06-21_08.44.32.png
          755 kB
        2. Big Caves.zip
          2 kB
        3. latest.log
          4.53 MB

        Issue Links

          Activity

            People

              Unassigned Unassigned
              Flashbulb Flashbulb
              Votes:
              8 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                CHK: