Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-226213

"filled" override in bundle item model no longer allows for values above 1.0

    XMLWordPrintable

    Details

    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      Using a resource pack that changes the model of "overfilled" bundles (using the predicate filled>1.0) no longer works in 21w20a.

      {
          "parent": "item/generated",
          "textures": {
              "layer0": "item/bundle"
          },
          "overrides": [
              { "predicate": { "filled": 0.01 }, "model": "item/bundle_filled" },
              { "predicate": { "filled": 1.01 }, "model": "item/bundle_overfilled" }
          ]
      }
      

      Reproduce:
      1) Create a world in 21w19a and give yourself a filled bundle, and an "overfilled" bundle

      /give @s bundle{Items:[{id:'minecraft:stone',Count:1b}]}
      /give @s bundle{Items:[{id:'minecraft:stone',Count:65b}]}
      

      2) Enable the attached resource pack
      3) Note that the items have unique textures
      4) Create a world in 21w20a (or upgrade that world), and the filled and overfilled bundles have the same textures.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            Deoxyribonucleic Evans DorkOrc
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated: