Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-213695

Structure blocks fail to place mushrooms when the only thing blocking direct sunlight is other blocks placed by the structure block

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 21w03a, 1.16.5, 21w05a, 21w16a, 21w17a, 21w18a, 21w20a, 1.17, 1.17.1
    • Fix Version/s: None
    • Labels:
    • Confirmation Status:
      Confirmed
    • Category:
      (Unassigned)

      Description

      That summary is kinda awkward, but I couldn't think of a better way to phrase it

      To reproduce

      1. Save the following configuration as a structure: 
      2. Load the structure back into the world someplace underneath the open sky, and notice that the mushroom isn't there

      If you generate it somewhere where the location of the mushroom is already dark enough for a mushroom to be placed, the mushroom will place successfully.

      The problem seems to be that the game isn't taking the other blocks in the structure into account when trying to place the mushroom.

      For further proof that lighting is the problem, try replacing the stone underneath the mushroom with mycelium and note that it generates just fine.

        Attachments

        1. result.png
          757 kB
          Sean
        2. structure-setup.png
          695 kB
          Sean

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              SeanWasTaken Sean
              Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: