Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-205877

"generator-settings" in server.properties not applying to flat world

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.16.4, 1.16.5, 21w13a, 1.17.1
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Confirmed
    • Category:
      Dedicated Server

      Description

      I know a lot of people have been having issues with "generator-settings" in server.properties not applying to flat worlds. I did a good amount of searching as was not able to find an answer.

      I did come across issue #MC-182421 which stated it was fixed.
      I used the settings from that issue that Bartosk posted:

      {"biome":"minecraft:plains","layers":[{"block":"minecraft:diamond_block","height":1}],"structures":{"village":{}}}
      

      I tested on 20w18a since that was the version that was claimed to work on.
      It worked. But when I tested in both 1.16 and 1.16.4 neither worked. I even tested on the latest snapshot, 20w46a, and still a no go.

      In the images, you will see the diamond block world worked in 20w18a, but the same value did not apply for any other version.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ShaneBolenback ShaneBee
              Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: