Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-196743

Custom/modified biomes don't work in the overworld

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 1.16.2 Pre-release 1
    • Fix Version/s: 1.16.2 Pre-release 2
    • Labels:
      None
    • Confirmation Status:
      Community Consensus
    • Category:
      Custom Worlds
    • Mojang Priority:
      Normal

      Description

      Trying to modify any pre-existing biome in the overworld won't load the biome, and trying to load any custom biome not in a custom dimension (or in single biome worlds) causes the same error. The log gives the warning "Unable to find spawn biome" and then spams "Recieved invalid biome id: -1" (I got over 70,000 of these in less than a minute) on world creation when trying to join your new world. There are no error messages, only warnings.

      To reproduce this, try to load any custom biome in a single biome world, or modify any existing biome in the default overworld and try to load up a world (I tried putting a snowy village in a plains biome to get this to work).

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            WafflesAreBetter Waffleboy
            Votes:
            4 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              CHK: