Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-193404

Changing a powered or activator rail to powered using a debug stick or /setblock does not work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: 1.16.1, 1.16.2, 1.16.3 Release Candidate 1, 1.16.3, 1.16.4, 20w46a, 20w51a, 21w03a
    • Fix Version/s: None
    • Labels:
      None
    • Confirmation Status:
      Confirmed
    • Category:
      Block states, Redstone
    • Mojang Priority:
      Normal

      Description

      The bug

      Whenever I try to make a powered or activator rail powered using commands, nothing happens.
      I've tried using a Debug Stick, doing /setblock ~ ~~ powered_rail[powered=true], and even put that command in a repeating command block and nothing happened.

        Attachments

        1. 2021-05-16_16.39.27.png
          2021-05-16_16.39.27.png
          377 kB
        2. 2021-05-16_16.39.32.png
          2021-05-16_16.39.32.png
          384 kB
        3. issue.png
          issue.png
          877 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              JasprMC Jasper Levin
              Votes:
              8 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: