Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-183786

Named seeds that are not numbers are not being recognized

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 20w20a, 20w20b
    • Fix Version/s: 20w21a
    • Labels:
    • Confirmation Status:
      Confirmed
    • Category:
      World generation
    • Mojang Priority:
      Important

      Description

      To Reproduce

      1. Create a world with seed a in 20w20a.
      2. Check the seed by using /seed command.
        • Expected: 97
        • Actual: a random number

      Original Description

      In the latest snapshot I tried using a world generated with the seed "a", which should be seed "97".

      However in this snapshot the seed I received was much longer, and resembled a seed that would generate randomly. I tried the same "a" seed again, and I received a different seed yet again. I tried this with other words and they all give back random seeds. When I tried the seed "1" the world generated with the seed "1", which leads me to believe this is only the case for seeds made up of letters.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              fry [Mojang] Georgii Gavrichev
              Reporter:
              AgentPaint agentpaint
              Votes:
              10 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                CHK: