Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-169408

Iron Golems Stop Spawning on Iron Farm

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Invalid
    • Affects Version/s: 1.15.1
    • Fix Version/s: None
    • Labels:
    • Environment:
      No village near by and iron farm about 100 blocks off ground
    • Confirmation Status:
      Community Consensus
    • Game Mode:
      Survival
    • Category:
      (Unassigned)

      Description

      Hey!

      i just spent 2 hours making a iron farm in minecraft, to my relief it worked! I made like 40 iron (on spawn chunk btw) and then I walked to my home assuming since on spawn chunk it would continue to work, after about 2 hours I come back and it is stalled at 52 iron. Iron golems stopped spawning so I then did the following to try to solve it:

      -Checked area using commands to make sure no iron golems are living near by

      -Killed villagers and replaced (took forever)

      -Killed Zombie and replaced (took forever)

      -Restarted Server (This is running on Aternos server but only me uses it atm because friend who is going to play hasn't had time to join yet)

      -This one is interesting: I tried making a iron golem above where they are supposed to spawn but when I finished nothing happend! I then tore it down and re did it on ground level and it worked. I then went back up and did it and it worked, very weird. but no iron golems spawning yet...

       

      I really need help fast! I also didnt change versions or do any mods or anything, just vanilla minecraft.

       

      VIDEO TO SEE IRON FARM SETUP AND GOLEMS NOT SPAWNING - https://streamable.com/4kphe

       

      EDIT/UPDATE TO PROBLEM:

      I just tried replacing all the beds and then closing off the zombie from villagers so they would sleep in beds and then opening it and it worked! I then left to head back home to test if it would continue come back in 30 minutes to see two stacks of iron and hear a iron golem dieing which meant it is still working... but then... everything stopped. I tried repeating bed trick/block off zombie trick again during day and night with no results so it is now broken again.

      It seems as if this may be that when I reload these chunks the beds reassign but since I can't "refix" it makes this really weird, keep in mind these are spawn chunks.

      I will continue to update this as I find stuff hopefully I get mod/admin/dev to respond soon!

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            GamingInReality Will
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              CHK: