Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-146763

Mobs not spawning across all dimensions.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Awaiting Response
    • Affects Version/s: Minecraft 19w12b
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Put your operating system (Windows 7, Windows XP, OSX) and Java version if you know it here
    • Confirmation Status:
      Unconfirmed

      Description

      SUMMARY:
      I was working with shulkers in the end, and I used a datapack to summon a shulker every time a enderman spawned inside a end-city, it worked for a while - and then I used commands to kill each mob separately. And now no mobs will spawn at all - across all the dimensions. (Overworld, Nether, The End).

      I did this - and I even tried restarting my game multiple times.
      /gamerule doMobSpawning True
      /difficulty Hard (switching between Peaceful and Hard, consistently).

      Not sure what is causing it.
      World Download

      HOW TO RE-CREATE
      1. Make a new world
      2. Add this datapack to allow shulkers to respawn in the end city (DL)
      3. Go to a endcity, and then remove all endstone around the end city, so only the endcity is there over the void (you can use commands to remove the endstone below the endcity).
      4. Remove the endcity (easier if it's a small one) and then make some spawning layers using purpur blocks (important - also shown on one of the pictures below).
      5. Endermen will spawn on it and some of them will turn into shulkers.
      6. Setup commandblocks to kill each mob separately.
      7. Now place a button on each commandblock you have setup to kill the mobs, and then hit it every time you see spawns, to constantly kill each mob (shulker and enderman).
      8. Do this for a couple of minutes, and mobs will stop spawning randomly, across all dimensions. And will never spawn again.

      I've managed to re-create this bug multiple times, following the steps above ^

      (Before you say it's because I'm using this specific datapack and there is something wrong with it.. you are wrong - I have used this datapack for a while, even in 1.13+) and it worked flawless, and didn't interfer with general mob spawning at all.
      I have even tried removing the datapack completely after the bug happens in the world, and it still doesn't spawn any mobs. Except for passive mobs - even at night on HARD difficulty and /gamerule doMobSpawning true - no spawns are happening.
      PICTURE

      I'm pretty sure this is a bug in the 1.14 snapshots.

      Pls fix Mojang!

        Attachments

        1. 2019-03-27_12.31.45.png
          3.93 MB
          dojofemy
        2. 2019-03-27_12.31.52.png
          1.72 MB
          dojofemy
        3. 2019-03-27_12.32.57.png
          4.31 MB
          dojofemy
        4. 2019-03-27_12.50.12.png
          1.79 MB
          dojofemy
        5. 2019-03-27_12.50.20.png
          1.57 MB
          dojofemy
        6. 2019-03-27_12.50.43.png
          3.99 MB
          dojofemy
        7. 2019-03-27_12.50.46.png
          1.96 MB
          dojofemy
        8. 2019-03-27_12.51.35.png
          2.39 MB
          dojofemy
        9. 2019-03-27_12.51.44.png
          2.98 MB
          dojofemy

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              femy dojofemy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: