Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-144752

Actavator rails ejecting mobs/players into block

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 1.13.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Windows 10, Java 1.8.0_51
      Discovered in Minecraft 1.13.2 with the Opifine mod

    • Confirmation Status:
      Unconfirmed
    • Category:
      (Unassigned)

      Description

      I have made a villager trading hall which used activator rails to eject the villagers into holding cells. Villagers are picked up by the minecart when they go over an activator rail and then are ejected on it where a piston pushes them into the holding cell. The issue is that sometimes when they are ejected, they get stuck in the blocks surrounding the area above the rail. This breaks the system because the pistons cant push them into the cells. I tested it with player too and the same result happened. I have tried to replicate this in a test world with no luck, but it always happens in survival. I first though the reason was that the blocks were glass blocks, so I replaced them with solid blocks. They still got ejected into the blocks and suffocated. I am almost positive that this is a bug, but if it's not is there a solution?
      In the screenshot you can see the villager's hitbox is slightly inside the glass block. This is not a directional issue because it happened in all directions.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Nightriderx1 Caleb Moak
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: