Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-1408

Javaw.exe keeps running after closing minecraft.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Invalid
    • Affects Version/s: Minecraft 1.4.2, Minecraft 1.4.4, Minecraft 1.4.5, Minecraft 1.4.7
    • Fix Version/s: None
    • Labels:
    • Environment:
      Windows 7 64-bit
      Java 1.7.0_05 64-bit
    • Confirmation Status:
      Community Consensus

      Description

      There has been a possible (prob 100%) fix
      Many others who had this problem.
      http://www.minecraftforum.net/topic/1405977-minecrafts-java-process-will-not-die-on-closure-or-at-all-for-that-matter/??

      Basically what happens is the following.
      1. Start minecraft
      2. Close minecraft
      3. check Task Manager
      4. and the javaw.exe continues to run. If you try to terminate it (both End Process and End Process Tree) it will either not do anything at all, or it will say "cannot terminate process" Also, using other 3rd party programs to terminate this process do not work either.

      I originally thought this was a Java issue. So I reinstalled Java, tried previous versions of java (1.6) as well as trying other programs that have java.
      Other programs that use Java have not shown this memory leak.

      I thought it may be a driver issue with perhaps ATI cards, since I saw many people with ATI cards that seem to have this problem. It turns out that some Nvidia cards also seem to have this problem.
      Other things I have tried are the following

      1. Clean update still causes the problem.
      2. Using a different launcher still causes the problem.
      3. Using batch files still causes the problem.
      4. Whether it Crashes, You click the x button, you press terminate the process, or you click the Quit Game button, it still causes the problem.
      5. Deleting 1.2.5 minecraft that for some reason gets downloaded in force update still causes the problem.
      6. Clicking End Process Tree or End Process still causes the problem.
      7. Using mods or not still cuases the problem.
      8. Having Java 7 Update 5 or Java 6 or Java 7 Update 3. It doesn't matter. It still causes it.

      It was discussed on the 1.3.1 talk on the wiki, and I believe it was also a bug report on the 1.3.1 Bug list, but was removed by someone.


      POSSIBLE FIX:
      I initially did not think about this, but after my problem was gone, I realized I uninstalled K9.
      Dean did a good job in testing and confirming this, and now many others have started to confirm.

      Since it seems that a good handful are having this problem, and finally getting it fixed here, I think this article should be archived for future reference.

      K9 Causes your computer to basically not shut down javaw.exe after you close minecraft. Simply remove the software to get rid of the problem. Perhaps someone request to K9 to fix it?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              firefwing24 Daniel Ahn
              Votes:
              26 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                CHK: